Show tool settings hides toolbar and side bars #111925

Closed
opened 2023-09-04 12:52:54 +02:00 by Luca Saiani · 5 comments

System Information
Operating system: Windows-10-10.0.19045-SP0 64 Bits
Graphics card: Quadro P2200/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 452.39

Blender Version
Broken: version: 3.6.0, branch: blender-v3.6-release, commit date: 2023-06-27 08:08, hash: c7fc78b81ecb
Worked: (newest version of Blender that worked as expected)

Short description of error
When enabling "show tool setting" in a 3D view, both toolbar and side bars are hidden. Switching off "show tool setting" shows the bars again.

Exact steps for others to reproduce the error
When "show tool settings" is enabled, the toolbar and tool settings disappear.
Also, the "adjust last operation" windows is not shown when it is supposed to be shown. Please also note that at the bottom of the 3D window a resizeble empty black area is shown.

The file was created with Blender 3.6. Opening the file file with blender 3.5 didn't solve the issue
Please note that this issue happens only with the attached files: importing all the context of the file in a new file works as expected. Newly created files are not affected.

As usual, thank you for all your work!

**System Information** Operating system: Windows-10-10.0.19045-SP0 64 Bits Graphics card: Quadro P2200/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 452.39 **Blender Version** Broken: version: 3.6.0, branch: blender-v3.6-release, commit date: 2023-06-27 08:08, hash: `c7fc78b81ecb` Worked: (newest version of Blender that worked as expected) **Short description of error** When enabling "show tool setting" in a 3D view, both toolbar and side bars are hidden. Switching off "show tool setting" shows the bars again. **Exact steps for others to reproduce the error** When "show tool settings" is enabled, the toolbar and tool settings disappear. Also, the "adjust last operation" windows is not shown when it is supposed to be shown. Please also note that at the bottom of the 3D window a resizeble empty black area is shown. The file was created with Blender 3.6. Opening the file file with blender 3.5 didn't solve the issue Please note that this issue happens only with the attached files: importing all the context of the file in a new file works as expected. Newly created files are not affected. As usual, thank you for all your work!
1.6 MiB
Luca Saiani added the
Priority
Normal
Type
Report
Status
Needs Triage
labels 2023-09-04 12:52:55 +02:00
Member

Not sure what exactly is the situation, but I suspect that the viewport region (at some point) has a very small size which in this case it will hide panels that are too tall/wide like the left/right side tool panels. Here either tool bar or side bar shows normally no matter whether I enable the "show tool settings" option with this file.

Could you try this file with 3.6.2 or 4.0?

Not sure what exactly is the situation, but I suspect that the viewport region (at some point) has a very small size which in this case it will hide panels that are too tall/wide like the left/right side tool panels. Here either tool bar or side bar shows normally no matter whether I enable the "show tool settings" option with this file. Could you try this file with 3.6.2 or 4.0?
YimingWu added
Status
Needs Information from User
and removed
Status
Needs Triage
labels 2023-09-04 14:22:30 +02:00
Author

Hi.

I opened the file with both 3.6.2 (on Windows) and with 4.0 (today's build, on Linux). On 3.6.2 the issue is still there, with 4.0 is "solved".

Definitely it is not a problem of window size (please see attached image)

I have also tried to start a new file, append the scene from the file which gives me issues, and then the problem is there again.

I can't upload the original file which gives me issues, since I am not allowed to upload file from work, but the blender file I have uploaded shows clearly the issue, which is what you can see in the screenshot below.

Please let me know if there is a way I can give you better information.

thanks,
Luca

Hi. I opened the file with both 3.6.2 (on Windows) and with 4.0 (today's build, on Linux). On 3.6.2 the issue is still there, with 4.0 is "solved". Definitely it is not a problem of window size (please see attached image) I have also tried to start a new file, append the scene from the file which gives me issues, and then the problem is there again. I can't upload the original file which gives me issues, since I am not allowed to upload file from work, but the blender file I have uploaded shows clearly the issue, which is what you can see in the screenshot below. Please let me know if there is a way I can give you better information. thanks, Luca
Member

The first screenshot looks like #111332. Are you sure you didn't save the file on 4.0 at some point?

The first screenshot looks like https://projects.blender.org/blender/blender/issues/111332. Are you sure you didn't save the file on 4.0 at some point?
Author

Yes, it may be since some times I move files from home computer (Blender 4.0) to office computer (Blender 3.6).
This would explain why I don't have this issue with new files created in 3.6.

I just tried to create a new file in 4.0 and open it in 3.6.2 (download today) and the issue is there (see screenshot).

I think it is the same regression #111332 you pointed out

Yes, it may be since some times I move files from home computer (Blender 4.0) to office computer (Blender 3.6). This would explain why I don't have this issue with new files created in 3.6. I just tried to create a new file in 4.0 and open it in 3.6.2 (download today) and the issue is there (see screenshot). I think it is the same regression #111332 you pointed out

I can't confirm, however this issue has been reported before, see #111332. Will merge reports. Please subscribe in #111332 if you want to see further updates

I can't confirm, however this issue has been reported before, see #111332. Will merge reports. Please subscribe in #111332 if you want to see further updates
Blender Bot added
Status
Archived
and removed
Status
Needs Information from User
labels 2023-09-04 17:45:23 +02:00
Iliya Katushenock added
Status
Duplicate
and removed
Status
Archived
labels 2023-09-04 17:45:28 +02:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser
Interest
Asset Browser Project Overview
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
4 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#111925
No description provided.