Mesh To Curve Node Is like merging edges to be one spline #112549

Closed
opened 2023-09-18 23:40:04 +02:00 by Ahmed Jarad · 7 comments

System Information
Operating system: Windows-10-10.0.19045-SP0 64 Bits
Graphics card: Radeon RX 570 Series ATI Technologies Inc. 4.5.0 Core Profile Context 23.Q3.1.230823

Blender Version
Broken: version: 3.6.2, branch: blender-v3.6-release, commit date: 2023-08-16 16:43, hash: e53e55951e7a
Worked: (3.4.0 maybe its not the last version is working but that what i have right now on my computer and it works as expected)

Short description of error
Placing Mesh To Curve node after Split Edges node not splitting Edges to Seperated Splines

Exact steps for others to reproduce the error

  1. Add curve
  2. Add new Geometry Node to It
  3. Add These Nodes connected Togother With This Order ...

Group Input(Geometry-Socket) -> Set Spline Type(Curve-Socket) ->Curve To Mesh in the "curve" socket ->Split Edges in the mesh socket -> mesh to Curve -> Group Output

4.Add A Viewer node and Check The Result

With the .blend file attached you just open it and find the result.

**System Information** Operating system: Windows-10-10.0.19045-SP0 64 Bits Graphics card: Radeon RX 570 Series ATI Technologies Inc. 4.5.0 Core Profile Context 23.Q3.1.230823 **Blender Version** Broken: version: 3.6.2, branch: blender-v3.6-release, commit date: 2023-08-16 16:43, hash: `e53e55951e7a` Worked: (3.4.0 maybe its not the last version is working but that what i have right now on my computer and it works as expected) **Short description of error** Placing Mesh To Curve node after Split Edges node not splitting Edges to Seperated Splines **Exact steps for others to reproduce the error** 1. Add curve 2. Add new Geometry Node to It 3. Add These Nodes connected Togother With This Order ... Group Input(Geometry-Socket) -> Set Spline Type<Put the type to Poly>(Curve-Socket) ->Curve To Mesh in the "curve" socket ->Split Edges in the mesh socket -> mesh to Curve -> Group Output 4.Add A Viewer node and Check The Result With the .blend file attached you just open it and find the result.
Ahmed Jarad added the
Status
Needs Triage
Priority
Normal
Type
Report
labels 2023-09-18 23:40:05 +02:00
Author

This bug is also appear on the game engine of blender UPBGE of the same version (3.6.2)

This bug is also appear on the game engine of blender UPBGE of the same version (3.6.2)
Member

Hi @end_ahmed , looks like it's the same problem as #109236. It has since been fixed already. You could try downloading latest 3.6 or 4.0 daily build and see.

Will close this issue. Thanks for the report. :D

Hi @end_ahmed , looks like it's the same problem as #109236. It has since been fixed already. You could try downloading latest 3.6 or 4.0 daily build and see. Will close this issue. Thanks for the report. :D
Blender Bot added
Status
Archived
and removed
Status
Needs Triage
labels 2023-09-19 04:06:49 +02:00
Author

@ChengduLittleA

I checked them they are not working

I Tried Latest 3.6 and Latest 4.0

@ChengduLittleA ### I checked them they are not working I Tried Latest 3.6 and Latest 4.0
Blender Bot added
Status
Needs Triage
and removed
Status
Archived
labels 2023-09-19 16:07:53 +02:00

@end_ahmed Hey, can you say what is latest 4.0 version have you check?

@end_ahmed Hey, can you say what is latest 4.0 version have you check?

I reproduced this bug in the latest official release, but not the latest daily build, so it appears the bug has been fixed already.

Please try the latest daily build: https://builder.blender.org/download/

I reproduced this bug in the latest official release, but not the latest daily build, so it appears the bug has been fixed already. Please try the latest daily build: https://builder.blender.org/download/
Germano Cavalcante added
Status
Needs Information from User
and removed
Status
Needs Triage
labels 2023-09-19 17:10:02 +02:00
Author

Its my bad sorry ,I enterd Archived Builds And installed the top one thinking that its the latest one ,but now i see that the order there isn't from newest to oldest,

I tried latest Blender 3.6.3 (71b55b491e) and its crashing me out of blender when i do the nodes setup

But its working as expected on the latest 4.0.0 (78315faf8f)

Its my bad sorry ,I enterd Archived Builds And installed the top one thinking that its the latest one ,but now i see that the order there isn't from newest to oldest, I tried latest Blender 3.6.3 (71b55b491e9c) and its crashing me out of blender when i do the nodes setup But its working as expected on the latest 4.0.0 (78315faf8fbd)

I can confirm the crash and created another report to track this issue. #112590

Thanks for the info.

I can confirm the crash and created another report to track this issue. #112590 Thanks for the info.
Blender Bot added
Status
Archived
and removed
Status
Needs Information from User
labels 2023-09-19 18:53:35 +02:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser
Interest
Asset Browser Project Overview
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
4 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#112549
No description provided.