Incorrect render pass color with overlapping geometry using Eevee #112576

Open
opened 2023-09-19 14:48:34 +02:00 by Joran · 4 comments

System Information
Operating system: Windows-10-10.0.22621-SP0 64 Bits
Graphics card: NVIDIA GeForce RTX 2060/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 528.02

Blender Version
Broken: version: 3.6.1, branch: blender-v3.6-release, commit date: 2023-07-17 12:50, hash: 8bda729ef4dc
Worked: Never, tested with 2.90.1 to confirm

Short description of error

Unlike a normal render, Eevee's diffuse color and emission render passes add the colors of overlapping geometry together. The expected behavior is that an emissive material has the same color in a normal render as a render pass.

In practice this behavior causes issues when you have a mesh that uses backface culling with overlapping geometry in places where a backface would be visible.

Eevee diffuse pass:

Pasted image 20230919133759.png

Cycles diffuse pass:

Pasted image 20230919133859.png

Steps to reproduce:

  1. View the diffuse color render pass in the viewport
  2. Assign material with grey base color to object
  3. Duplicate the object
  4. (Optional) flip the normals of the duplicated object
  5. (Optional) enable backface culling in the material
  6. The color is brighter than expected

Here's a blend file that shows the problem

**System Information** Operating system: Windows-10-10.0.22621-SP0 64 Bits Graphics card: NVIDIA GeForce RTX 2060/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 528.02 **Blender Version** Broken: version: 3.6.1, branch: blender-v3.6-release, commit date: 2023-07-17 12:50, hash: `8bda729ef4dc` Worked: Never, tested with 2.90.1 to confirm **Short description of error** Unlike a normal render, Eevee's diffuse color and emission render passes add the colors of overlapping geometry together. The expected behavior is that an emissive material has the same color in a normal render as a render pass. In practice this behavior causes issues when you have a mesh that uses backface culling with overlapping geometry in places where a backface would be visible. Eevee diffuse pass: ![Pasted image 20230919133759.png](/attachments/a7a0597a-f9d0-4c79-875f-76499708e318) Cycles diffuse pass: ![Pasted image 20230919133859.png](/attachments/7246f6c3-d6b4-4877-9ea5-cc00f1949190) Steps to reproduce: 1. View the diffuse color render pass in the viewport 2. Assign material with grey base color to object 3. Duplicate the object 4. (Optional) flip the normals of the duplicated object 5. (Optional) enable backface culling in the material 6. The color is brighter than expected [Here's a blend file that shows the problem](/attachments/41e375d7-5410-47eb-886b-67c517930da2)
Joran added the
Priority
Normal
Type
Report
Status
Needs Triage
labels 2023-09-19 14:48:35 +02:00

I can confirm, however this issue has been reported before, see #96475. Will merge reports. Please subscribe in #96475 if you want to see further updates

I can confirm, however this issue has been reported before, see #96475. Will merge reports. Please subscribe in #96475 if you want to see further updates
Blender Bot added
Status
Archived
and removed
Status
Needs Triage
labels 2023-09-19 18:19:27 +02:00
Iliya Katushenock added
Status
Duplicate
Interest
EEVEE & Viewport
and removed
Status
Archived
labels 2023-09-19 18:19:43 +02:00
Author

@mod_moder This issue is different, because it's specific to Eevee's render passes. It doesn't have to do with Cycles. Eevee doesn't have this specific issue with overlapping geometry. The behavior I'm talking about only changes once a render pass is used. Normal renders work, render passes don't.

The image and emission passes should match up perfectly in this scenario:

image

If this is a known trade-off in Eevee's rendering I'm fine with it and wouldn't have made an issue, but because there's different behavior in render passes I suspect it's a bug.

@mod_moder This issue is different, because it's specific to Eevee's render passes. It doesn't have to do with Cycles. Eevee doesn't have this specific issue with overlapping geometry. The behavior I'm talking about only changes once a render pass is used. Normal renders work, render passes don't. The image and emission passes should match up perfectly in [this scenario](/attachments/d5770e9d-2720-4c74-8c92-e32f4420c73d): ![image](/attachments/249d2729-d98b-46eb-8cc1-3342b633c376) If this is a known trade-off in Eevee's rendering I'm fine with it and wouldn't have made an issue, but because there's different behavior in render passes I suspect it's a bug.
Joran reopened this issue 2023-09-19 18:51:44 +02:00
Blender Bot added
Status
Needs Triage
and removed
Status
Duplicate
labels 2023-09-19 18:51:45 +02:00

I can confirm that the diffuse pass becomes more intense when the geometry overlaps.
But I feel like we're dealing with undefined behavior.
Geometries that overlap are not desirable and do not have a defined behavior.
Even if the result is not the same as Cycles, I don't think this undefined behavior deserves to be explored and "solved" as if it were the result of a bug.

I'll leave the decision to the 'Eevee & Viewport' team.

I can confirm that the diffuse pass becomes more intense when the geometry overlaps. But I feel like we're dealing with undefined behavior. Geometries that overlap are not desirable and do not have a defined behavior. Even if the result is not the same as Cycles, I don't think this undefined behavior deserves to be explored and "solved" as if it were the result of a bug. I'll leave the decision to the 'Eevee & Viewport' team.
Author

@mano-wii That's fair. It's a very niche edge case. I only ran into it because I'm using backface culling to optimize game models and it happened to cause issues with render passes.

That being said, I just tested the same setup in Eevee Next and it doesn't seem to cause any issues there.

image

@mano-wii That's fair. It's a very niche edge case. I only ran into it because I'm using backface culling to optimize game models and it happened to cause issues with render passes. That being said, I just tested the same setup in Eevee Next and it doesn't seem to cause any issues there. ![image](/attachments/47dca618-469d-4fb2-b11d-43941ba95c63)
195 KiB
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser Project (Legacy)
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
3 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#112576
No description provided.