"Jump to keyframe" grayed out. Unable to jump between keyframes. #112673

Closed
opened 2023-09-21 15:56:55 +02:00 by zmsfm · 10 comments

System Information
Operating system: Windows-10-10.0.19045-SP0 64 Bits
Graphics card: NVIDIA GeForce RTX 3090/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 537.34

Blender Version
Broken: version: 3.6.3, branch: blender-v3.6-release, commit date: 2023-09-21 06:06, hash: d3e6b08276ba
Worked: 3.6.2 and also 4.0
caused by 56781c80b7 because the follow up commit 211d631428 was not merged to 3.6.3

Short description of error
The "jump to keyframes" buttons in the timeline are grayed out, using the arrows doesn't allow me to jump between keyframes.

Long description
The issue is not linked to a single project but to any project I make. I tried reinstalling blender, resetting all the settings to "Factory Settings". While in "Graph Editor" by moving the curse in it I can Jump betten the keyframes but in the "Timeline", "Dopesheet" and "Viewport" by using the arrows or "Favourite menu" or the button itself, nothing happens as the function itself is grayed out.

I also tried to disable all the addons but the issue persisted.

How it happend
I have no idea how it happened.

**System Information** Operating system: Windows-10-10.0.19045-SP0 64 Bits Graphics card: NVIDIA GeForce RTX 3090/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 537.34 **Blender Version** Broken: version: 3.6.3, branch: blender-v3.6-release, commit date: 2023-09-21 06:06, hash: `d3e6b08276ba` Worked: 3.6.2 and also 4.0 caused by 56781c80b7 because the follow up commit 211d631428 was not merged to 3.6.3 **Short description of error** The "jump to keyframes" buttons in the timeline are grayed out, using the arrows doesn't allow me to jump between keyframes. **Long description** The issue is not linked to a single project but to any project I make. I tried reinstalling blender, resetting all the settings to "Factory Settings". While in "Graph Editor" by moving the curse in it I can Jump betten the keyframes but in the "Timeline", "Dopesheet" and "Viewport" by using the arrows or "Favourite menu" or the button itself, nothing happens as the function itself is grayed out. I also tried to disable all the addons but the issue persisted. **How it happend** I have no idea how it happened.
zmsfm added the
Status
Needs Triage
Type
Report
Priority
Normal
labels 2023-09-21 15:56:56 +02:00
Contributor

Looks like this is 3.6.2 -> 3.6.3 regression. Not happening with 4.0 alpha.

Looks like this is 3.6.2 -> 3.6.3 regression. Not happening with 4.0 alpha.

Can you upload a simple file that shows the issue so we can reproduce it on our end.
Also please check you have no addons enabled that could interfere with Blender

Can you upload a simple file that shows the issue so we can reproduce it on our end. Also please check you have no addons enabled that could interfere with Blender
Author

Here's a project with the default cube and two keyframes on the cube. I filtered all the addons but the issue persists.

Here's a project with the default cube and two keyframes on the cube. I filtered all the addons but the issue persists.
Christoph Lendenfeld added
Status
Confirmed
and removed
Status
Needs Triage
labels 2023-09-21 16:12:15 +02:00

can confirm. This is indeed a regression from 3.6.2 to 3.6.3
just checking where it came from

can confirm. This is indeed a regression from 3.6.2 to 3.6.3 just checking where it came from
Christoph Lendenfeld self-assigned this 2023-09-21 16:13:49 +02:00

caused by 56781c80b7 because the follow up commit 211d631428 was not merged to 3.6.3

caused by 56781c80b7 because the follow up commit 211d631428 was not merged to 3.6.3
Author

I'm sorry, I personally have no experience with coding. Is there anything I can do to fix it or help? While I rely on it quite a bit, I'd be happy to wait for the next update. Otherwise, I could switch to another version but rolling back to a previous version may make my projects not openable I suppose.

I'm sorry, I personally have no experience with coding. Is there anything I can do to fix it or help? While I rely on it quite a bit, I'd be happy to wait for the next update. Otherwise, I could switch to another version but rolling back to a previous version may make my projects not openable I suppose.
Christoph Lendenfeld added
Priority
High
and removed
Priority
Normal
labels 2023-09-21 16:30:49 +02:00

the triaging team will decide what's going to happen. In the meantime use 3.6.2
You can still open files saved with 3.6.3. Make sure to save a new version just in case

the triaging team will decide what's going to happen. In the meantime use 3.6.2 You can still open files saved with 3.6.3. Make sure to save a new version just in case
Author

Thank you very very much for the help!! :D

Thank you very very much for the help!! :D
Jesse Yurkovich added the
Module
Animation & Rigging
label 2023-09-21 21:59:07 +02:00

The up/down arrows are also broken.

I noticed that I can only do up/down arrow now in F-curve editor, which is a drag (haha see what i did there). Can't do it in viewport or timeline/action editor/dope sheet anymore like in 3.6.2.

Another artist wrote to me this morning about it and was guessing it may have had to do with the jump to keyframe changes with NLA and the graph editor #110789 and #108549 but you guys have a handle on it already it looks like

The up/down arrows are also broken. I noticed that I can only do up/down arrow now in F-curve editor, which is a drag (haha see what i did there). Can't do it in viewport or timeline/action editor/dope sheet anymore like in 3.6.2. Another artist wrote to me this morning about it and was guessing it may have had to do with the jump to keyframe changes with NLA and the graph editor #110789 and #108549 but you guys have a handle on it already it looks like
Member

This should now be fixed 3.6.4 RC from https://builder.blender.org/download/daily/
See #109399 / fa6261e53a

It looks like we'll do 3.6.4 tomorrow.
So will close now.

This should now be fixed 3.6.4 RC from https://builder.blender.org/download/daily/ See https://projects.blender.org/blender/blender/issues/109399 / fa6261e53a It looks like we'll do 3.6.4 tomorrow. So will close now.
Blender Bot added
Status
Archived
and removed
Status
Confirmed
labels 2023-09-25 11:13:06 +02:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser
Interest
Asset Browser Project Overview
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
5 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#112673
No description provided.