Production File broke between LTS releases #113018

Closed
opened 2023-09-28 16:07:31 +02:00 by Simon Thommes · 9 comments
Member

Blender Version
Broken: version: 3.6.3, 4.0 beta, 4.1 alpha
Worked: 3.6.2

Short description of error
image

Exact steps for others to reproduce the error
File:
https://studio.blender.org/films/wing-it/3c308f54ee719e/?asset=6953

**Blender Version** Broken: version: 3.6.3, 4.0 beta, 4.1 alpha Worked: 3.6.2 **Short description of error** ![image](/attachments/f6905482-e482-42a7-9a37-0ba8e30935cf) **Exact steps for others to reproduce the error** File: https://studio.blender.org/films/wing-it/3c308f54ee719e/?asset=6953
478 KiB
Simon Thommes added the
Priority
Normal
Status
Needs Triage
Type
Report
labels 2023-09-28 16:07:32 +02:00

It is broken on 3.6.3 already even (I will update the description).

It is broken on 3.6.3 already even ~~(I will update the description)~~.

And the issue is present both in main (4.1) and 4.0 branches.

And the issue is present both in main (4.1) and 4.0 branches.
Author
Member

I spoke with @JacquesLucke
This seems to be due to some changes in the edge split node that were backported to fix some bugs and cause a difference index order.
Since this setup relies on a consistent index order it breaks. I was told that we should just not rely on index order, which is generally fair, while I still think there's a point to be made to put in an effort to still keep this reliable between LTS versions.
Regardless, we can adjust the setup in the files to not rely on index order and use UV sampling instead. But this brings up a general discussion that if we should never rely on indices for data transfer (except for cases where that can always be ensured, which is a bit fuzzy), there needs to be a better general solution in geometry nodes to transfer data between geometries, that is more robust.
UVs work great. But they require some manual management and the sampling is less efficient. Some similar ID attribute based transfer could work for transferring between discrete elements, rather than interpolating.

I spoke with @JacquesLucke This seems to be due to some changes in the edge split node that were backported to fix some bugs and cause a difference index order. Since this setup relies on a consistent index order it breaks. I was told that we should just not rely on index order, which is generally fair, while I still think there's a point to be made to put in an effort to still keep this reliable between LTS versions. Regardless, we can adjust the setup in the files to not rely on index order and use UV sampling instead. But this brings up a general discussion that if we should never rely on indices for data transfer (except for cases where that can always be ensured, which is a bit fuzzy), there needs to be a better general solution in geometry nodes to transfer data between geometries, that is more robust. UVs work great. But they require some manual management and the sampling is less efficient. Some similar ID attribute based transfer could work for transferring between discrete elements, rather than interpolating.
Member

Indeed, this isn't a bug, since these indices from geometry processing can change between Blender versions. Obviously it's far better if we don't change them between LTS point releases. I spent a while trying to avoid that here, but ended up only being confident with a more complete rewrite that I understood properly (be2df46afe).

Indeed, this isn't a bug, since these indices from geometry processing can change between Blender versions. Obviously it's far better if we don't change them between LTS point releases. I spent a while trying to avoid that here, but ended up only being confident with a more complete rewrite that I understood properly (be2df46afe58a662b2d0308906a9927e72f4629a).
Blender Bot added
Status
Archived
and removed
Status
Confirmed
labels 2023-09-29 02:41:00 +02:00

Obviously it's far better if we don't change them between LTS point releases.

I know it is not an easy call to make either way, but I would go a step further and be more strict on what passes as a LTS-acceptable fix.

While I understand a bug fix leading to changes in files, I don't think it is ok in-between LTS`. And all-in-all I would treat the original 3.6.0 Blender as the reference point (to avoid the argument that if we revert the fix, we would once again be breaking things).

From looking at be2df46afe the situation is not as simple as reverting something though. It feels like there were a bunch of commits leading to the final solution?

My question is, what would be the consequence of reverting the fix? How "bad" the original issue was? How doable it is to pin-point one commit to make the production file to work as before?


Just to illustrate my point, I was literally yesterday recommending an LTS upgrade for someone using 3.6.1 and experiencing crashes. Upgrading from 3.6.1 to 3.6.4 should be a no-brainer.

> Obviously it's far better if we don't change them between LTS point releases. I know it is not an easy call to make either way, but I would go a step further and be more strict on what passes as a LTS-acceptable fix. While I understand a bug fix leading to changes in files, I don't think it is ok in-between LTS`. And all-in-all I would treat the original 3.6.0 Blender as the reference point (to avoid the argument that if we revert the fix, we would once again be breaking things). From looking at be2df46afe58 the situation is not as simple as reverting something though. It feels like there were a bunch of commits leading to the final solution? My question is, what would be the consequence of reverting the fix? How "bad" the original issue was? How doable it is to pin-point one commit to make the production file to work as before? --- Just to illustrate my point, I was literally yesterday recommending an LTS upgrade for someone using 3.6.1 and experiencing crashes. Upgrading from 3.6.1 to 3.6.4 should be a no-brainer.
Member

If revert the fix, the split edges node will skip loose edges again (it will also be much slower, but that's probably not so relevant). I think that's a worse situation than changes in indices, which people don't often depend on, and the manual even recommends against it.

If revert the fix, the split edges node will skip loose edges again (it will also be much slower, but that's probably not so relevant). I think that's a worse situation than changes in indices, which people don't often depend on, and the manual even recommends against it.
Author
Member

the split edges node will skip loose edges again (it will also be much slower, but that's probably not so relevant)

I honestly don't see why that would be an issue if that's already how the behavior for 3.6.2 was. That doesn't sound like a bug to me. The edit mode operator also skips loose edges afaict. Can you point me to the issue where this was discussed, so I can understand better?

> the split edges node will skip loose edges again (it will also be much slower, but that's probably not so relevant) I honestly don't see why that would be an issue if that's already how the behavior for 3.6.2 was. That doesn't sound like a bug to me. The edit mode operator also skips loose edges afaict. Can you point me to the issue where this was discussed, so I can understand better?
Member

#109236

It's definitely a bug, and a bad one IMO. People relied on that behavior when dealing with curves. The edit mode operator doesn't skip loose edges, I just tested it.

#109236 It's definitely a bug, and a bad one IMO. People relied on that behavior when dealing with curves. The edit mode operator doesn't skip loose edges, I just tested it.
Author
Member

Ah, thanks for clarifying. Looks like I had a misunderstanding what should happen with splitting loose edges. And yea, if it's a regression then I can see how it's a bug

Ah, thanks for clarifying. Looks like I had a misunderstanding what should happen with splitting loose edges. And yea, if it's a regression then I can see how it's a bug
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser
Interest
Asset Browser Project Overview
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
3 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#113018
No description provided.