Node tools: in curves sculpt mode, changing values in redo panel refresh asset browser #113040

Closed
opened 2023-09-29 04:34:42 +02:00 by Sun Kim · 4 comments
Contributor

Blender Version
Broken: version: 4.1.0 Alpha, branch: main, commit date: 2023-09-28 04:28, hash: ca9c6372c94c
Worked: n/a

Short description of error

When using node tool in curves sculpt mode, changing values in the redo panel refreshes asset browser every time, makes the operation slower.

Exact steps for others to reproduce the error

You can see that it refreshes every time value is changed. Not happens with edit mode or mesh edit/sculpt modes.

node_tool_issue_in_curves_sculpt.blend

**Blender Version** Broken: version: 4.1.0 Alpha, branch: main, commit date: 2023-09-28 04:28, hash: `ca9c6372c94c` Worked: n/a **Short description of error** When using node tool in curves sculpt mode, changing values in the redo panel refreshes asset browser every time, makes the operation slower. **Exact steps for others to reproduce the error** <video src="/attachments/7026b24c-08d8-4e11-9137-936faf56bcd5" title="blender_h17cSF3QLX.mp4" controls></video> You can see that it refreshes every time value is changed. Not happens with edit mode or mesh edit/sculpt modes. [node_tool_issue_in_curves_sculpt.blend](/attachments/2f31530b-4444-4e15-87e9-6e705b6a4b2d)
Sun Kim added the
Priority
Normal
Type
Report
Status
Needs Triage
labels 2023-09-29 04:34:43 +02:00

Can you upload the script you are using?

Can you upload the script you are using?
Richard Antalik added
Status
Needs Information from User
and removed
Status
Needs Triage
labels 2023-09-29 05:21:58 +02:00
Author
Contributor

Can you upload the script you are using?

I didn't use any custom script. Maybe it was misleading that I uploaded a simpler reproduction file that looks different with the video.

Video using the simpler file.

> Can you upload the script you are using? I didn't use any custom script. Maybe it was misleading that I uploaded a simpler reproduction file that looks different with the video. Video using the simpler file. <video src="/attachments/70ca25fe-be36-4f54-a081-9d97ad1c5f4c" title="blender_GzCfiWHyAs.mp4" controls></video>

Eh sorry, was using 4.0, I thought you are using some addon. Can confirm the issue.

Looking at #101778, this is mentioned in polishing section - "Resolve flickering in asset browser when using redo panel". This is not "implemented" yet and there fore not a bug, so will close this report. Thanks for reporting though.

Eh sorry, was using 4.0, I thought you are using some addon. Can confirm the issue. Looking at #101778, this is mentioned in polishing section - "Resolve flickering in asset browser when using redo panel". This is not "implemented" yet and there fore not a bug, so will close this report. Thanks for reporting though.
Member

This is not "implemented" yet and there fore not a bug, so will close this report. Thanks for reporting though.

You hit the wrong button :)

> This is not "implemented" yet and there fore not a bug, so will close this report. Thanks for reporting though. You hit the wrong button :)
Blender Bot added
Status
Archived
and removed
Status
Needs Information from User
labels 2023-10-20 08:19:18 +02:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser
Interest
Asset Browser Project Overview
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
3 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#113040
No description provided.