MTLCommandBufferErrorDomain - Window update stalling in workbench and wireframe #116928

Open
opened 2024-01-09 11:10:19 +01:00 by Ole Prinds · 10 comments

System Information
Operating system: MacOS 12.6
Graphics card: Radeon Pro Vega 20 4 GB

Blender Version
Broken: 4.0.2
Worked: 3.6.7

Short description of error
With the attached blend file the window drawing stalls when the mesh in the scene is close to the viewport camera view. Viewed from a far it is working, but zooming in near the objects and panning around will make it stall. At first the whole computer stalls, but later only blender stalls. Sometimes it recovers temporarily. Wireframe and workbench render is affected. Eevee is not.

The mesh is bad mesh imported from Sketchup, but it does work in older versions of blender (3.6.7 and before).

Exact steps for others to reproduce the error

  1. Open attached .blend
  2. Use workbench or wireframe render mode
  3. zoom in near the mesh in the scene and pan around. Eventually it will stall.

I have attached log excerpts for workbench and wireframe modes..

**System Information** Operating system: MacOS 12.6 Graphics card: Radeon Pro Vega 20 4 GB **Blender Version** Broken: 4.0.2 Worked: 3.6.7 **Short description of error** With the attached blend file the window drawing stalls when the mesh in the scene is close to the viewport camera view. Viewed from a far it is working, but zooming in near the objects and panning around will make it stall. At first the whole computer stalls, but later only blender stalls. Sometimes it recovers temporarily. Wireframe and workbench render is affected. Eevee is not. The mesh is bad mesh imported from Sketchup, but it does work in older versions of blender (3.6.7 and before). **Exact steps for others to reproduce the error** 1. Open attached .blend 2. Use workbench or wireframe render mode 3. zoom in near the mesh in the scene and pan around. Eventually it will stall. I have attached log excerpts for workbench and wireframe modes..
Ole Prinds added the
Status
Needs Triage
Type
Report
Priority
Normal
labels 2024-01-09 11:10:19 +01:00
Author

Possibly related to #117379, #115784 and #117357

Possibly related to #117379, #115784 and #117357
Iliya Katushenock added the
Platform
macOS
Interest
EEVEE & Viewport
labels 2024-01-22 16:54:52 +01:00
Author

And just to be clear, the problem does not appear in Eevee. Only in workbench and wireframe mode.

And just to be clear, the problem does <u>not</u> appear in Eevee. Only in workbench and wireframe mode.
Member

problem does not appear in Eevee. Only in workbench and wireframe mode.

Maybe the workbench rewrite caused this? Does this still happen in 4.1 build: https://builder.blender.org/download/daily/

> problem does not appear in Eevee. Only in workbench and wireframe mode. Maybe the workbench rewrite caused this? Does this still happen in 4.1 build: https://builder.blender.org/download/daily/
Pratik Borhade added
Status
Needs Information from User
and removed
Status
Needs Triage
labels 2024-02-05 05:05:27 +01:00
Author

Yes, I have just tested in Version 4.1.0 (4.1.0 2024-01-23), and it does still happen.

Yes, I have just tested in Version 4.1.0 (4.1.0 2024-01-23), and it does still happen.
Pratik Borhade added
Status
Needs Triage
and removed
Status
Needs Information from User
labels 2024-02-06 05:03:31 +01:00
Member

Thanks.
@Michael-Parkin-White-Apple @pragma37 , hi can you check? we already have few similar reports on intel processors.

Thanks. @Michael-Parkin-White-Apple @pragma37 , hi can you check? we already have few similar reports on intel processors.
Author

Also just tested on Version 4.1.0 (4.1.0 2024-02-05), and the problem also appears in that version.

Let me know if there are any logs I can collect or things to try out.

Also just tested on Version 4.1.0 (4.1.0 2024-02-05), and the problem also appears in that version. Let me know if there are any logs I can collect or things to try out.
Member

Looking at the other reports, it seems to be a Metal-only issue, so I can't reproduce it myself.

Looking at the other reports, it seems to be a Metal-only issue, so I can't reproduce it myself.
Miguel Pozo added the
Interest
Workbench
label 2024-02-06 19:46:51 +01:00
Author

Still happens in 4.1 Beta and 4.2 Alpha.

Still happens in 4.1 Beta and 4.2 Alpha.
Member

Cannot repro in

**System Information**
Operating system: macOS-14.4.1-arm64-arm-64bit 64 Bits
Graphics card: Metal API Apple M2 1.2
version: 4.0.2, branch: blender-v4.0-release, commit date: 2023-12-05 07:41, hash: `9be62e85b727`
Cannot repro in ``` **System Information** Operating system: macOS-14.4.1-arm64-arm-64bit 64 Bits Graphics card: Metal API Apple M2 1.2 version: 4.0.2, branch: blender-v4.0-release, commit date: 2023-12-05 07:41, hash: `9be62e85b727` ```
Author

Any chance that this bug can be included in the bcon3 for 4.2?

It is still not working with the newest 4.2 beta 4bff6ba6558b

Any chance that this bug can be included in the bcon3 for 4.2? It is still not working with the newest [4.2 beta 4bff6ba6558b](https://projects.blender.org/blender/blender/commit/4bff6ba6558b)
Miguel Pozo added
Module
EEVEE & Viewport
and removed
Interest
EEVEE & Viewport
labels 2024-06-28 15:28:51 +02:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Asset Browser Project
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
4 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#116928
No description provided.