When inserting a new keyframe on a bone (and two armatures share the same action), Blender seems to not play keyframed bone constraint influences on non active armatures (or the active one sometimes) in the scene #117052

Closed
opened 2024-01-12 03:58:25 +01:00 by RYAN-JONES-RICHARDSON · 3 comments

System Information
Operating system: Windows 10
Graphics card: 1080ti

Blender 4.0.2
Broken: 4.0.2 9be62e85b7
Worked: As far as I can it tell it never has been fixed, at least in 3.x, I opened the file in 3.6 and it does the same thing.

**You have the same action on two separate armatures, and the animations bone constraints influence keyframes stop playing when you keyframe a bone on one or the other. It stops animating the influence on the other armatures in the scene even though both have the action active on them.

There are two armatures in this scene with a bone constraint influence on them; on "b_gun_r" the bone called "b_magazine" has a bone constraint child of called "follow hand" keyframed on frames 11 and 12 image
The second one on the control rig is on bone "c_hand_ik.l" and is a child of constraint called follow right hand keyframed on frames 11 and 12.
image

This older bug may be related:

#46344

**

Steps to reproduce

  1. Open the blend file animation_constraint_break

  2. Play the animation, it should look like this:
    https://youtu.be/p0o-VT2rzWw

  3. Now keyframe the selected bone, b_magazine (on fp_gun_r)

  4. Play the animation, it should look like this:
    https://youtu.be/LM_vuj53odk

  5. If you Keyframe keyframe c_hand_ik.l on the control_rig armature instead you will get this:
    https://youtu.be/eR27IrEKp18

I don't really know how i got the animation to play on both at once, seems to be really finnicky, I tested with other people and they got the same issue.

**System Information** Operating system: Windows 10 Graphics card: 1080ti **Blender 4.0.2** Broken: 4.0.2 9be62e85b727 Worked: As far as I can it tell it never has been fixed, at least in 3.x, I opened the file in 3.6 and it does the same thing. **You have the same action on two separate armatures, and the animations bone constraints influence keyframes stop playing when you keyframe a bone on one or the other. It stops animating the influence on the other armatures in the scene even though both have the action active on them. There are two armatures in this scene with a bone constraint influence on them; on "b_gun_r" the bone called "b_magazine" has a bone constraint child of called "follow hand" keyframed on frames 11 and 12 ![image](/attachments/3524c8a4-1247-4dda-afd4-7b4047c8019a) The second one on the control rig is on bone "c_hand_ik.l" and is a child of constraint called follow right hand keyframed on frames 11 and 12. ![image](/attachments/0576ec4d-a029-43b5-b54a-f7177dc78642) This older bug may be related: https://projects.blender.org/blender/blender/issues/46344 ** **Steps to reproduce** 1. Open the blend file animation_constraint_break 2. Play the animation, it should look like this: https://youtu.be/p0o-VT2rzWw 3. Now keyframe the selected bone, b_magazine (on fp_gun_r) 4. Play the animation, it should look like this: https://youtu.be/LM_vuj53odk 5. If you Keyframe keyframe c_hand_ik.l on the control_rig armature instead you will get this: https://youtu.be/eR27IrEKp18 I don't really know how i got the animation to play on both at once, seems to be really finnicky, I tested with other people and they got the same issue.
RYAN-JONES-RICHARDSON added the
Status
Needs Triage
Priority
Normal
Type
Report
labels 2024-01-12 03:58:26 +01:00
RYAN-JONES-RICHARDSON changed title from When inserting a new keyframe on a bone (and two armatures share the same action), Blender seems to not play keyframed bone constraints on non active armatures (or the active one sometimes) in the scene to When inserting a new keyframe on a bone (and two armatures share the same action), Blender seems to not play keyframed bone constraint influences on non active armatures (or the active one sometimes) in the scene 2024-01-12 04:01:35 +01:00

Also tested this with different actions on each armature and the influence keyframes didn't seem to play on the other armature ether

Also tested this with different actions on each armature and the influence keyframes didn't seem to play on the other armature ether

The only workaround i've found so far is setting up your rig constraints in a way where you keep any bone constraint influence keyframes on a single rig

The only workaround i've found so far is setting up your rig constraints in a way where you keep any bone constraint influence keyframes on a single rig

There are bunch of dependency cycles. You can see these when you open system console. Until you resolve these, the animation may be buggy, but that is expected behavior.

There are bunch of dependency cycles. You can see these when you open system console. Until you resolve these, the animation may be buggy, but that is expected behavior.
Blender Bot added
Status
Archived
and removed
Status
Needs Triage
labels 2024-01-16 20:59:26 +01:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Asset Browser Project
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
2 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#117052
No description provided.