Regression: Weird lines on the mesh using sculpt color filter #117971

Closed
opened 2024-02-08 05:07:20 +01:00 by ThinkingPolygons · 3 comments

Blender Version
Broken: blender-4.2.0-alpha+main.412b279629af-windows.amd64-release
Worked: 3.0 maybe?

Short description of error
Seems related to #117824 (Sculpt: Color Filter crash) but I was told to create a separate report, so:

if before you apply the color filter you do something, like a brush stroke, then apply the filter, then undo and redo, some weird lines appear on the mesh. please see the video below

Exact steps for others to reproduce the error
File/New/Sculpting
Perform a brush stroke on the mesh
Choose the Color Filter tool... pick a color... then click and drag in the viewport from left to right to fill the object with the color
Undo
Redo
as result, some weird lines will appear on the mesh

and if you undo twice and then redo it crashes like in #117824

**Blender Version** Broken: blender-4.2.0-alpha+main.412b279629af-windows.amd64-release Worked: 3.0 maybe? **Short description of error** Seems related to #117824 (Sculpt: Color Filter crash) but I was told to create a separate report, so: if before you apply the color filter you do something, like a brush stroke, then apply the filter, then undo and redo, some weird lines appear on the mesh. please see the video below **Exact steps for others to reproduce the error** File/New/Sculpting Perform a brush stroke on the mesh Choose the Color Filter tool... pick a color... then click and drag in the viewport from left to right to fill the object with the color Undo Redo as result, some weird lines will appear on the mesh <video controls="" src="https://projects.blender.org/attachments/fc62f5a1-e9b4-4f9d-9fbd-8cb3bf791877"></video> and if you undo twice and then redo it crashes like in #117824
ThinkingPolygons added the
Priority
Normal
Type
Report
Status
Needs Triage
labels 2024-02-08 05:07:21 +01:00
Member

Thanks for opening new report. Can confirm. This doesn't happen in 4.0

Thanks for opening new report. Can confirm. This doesn't happen in 4.0
Pratik Borhade changed title from Weird lines on the mesh using sculpt color filter to Regression: Weird lines on the mesh using sculpt color filter 2024-02-08 07:19:55 +01:00
Member

looks like an "off by one", will check

looks like an "off by one", will check
Member

Not 100% sure this is the correct solution, but fix is in !117986

Not 100% sure this is the correct solution, but fix is in !117986
Blender Bot added
Status
Resolved
and removed
Status
Confirmed
labels 2024-02-08 14:50:13 +01:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Asset Browser Project
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
3 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#117971
No description provided.