macOS: Abnormal termination on exit after playback #121015

Closed
opened 2024-04-24 11:59:51 +02:00 by Sergey Sharybin · 15 comments

System Information
Operating system: macOS-14.4.1-arm64-arm-64bit 64 Bits
Graphics card: Metal API Apple M2 Ultra 1.2

Blender Version
Broken: version: 4.2.0 Alpha, branch: main, commit date: 2024-04-23 21:08, hash: ce768d43a121
Worked: Prior 43307b667d

Short description of error

Blender aborts on exit due to incorrect deinitialization in the OpenCloseDevice(). Note the STL documentation of std::thread: If *this has an associated thread (joinable() == true), std::terminate() is called.

There is no code which guarantees that OpenCloseDevice::m_delayed_close_thread is not joinable upon ~OpenCloseDevice(), which leads to the termination, as per the std::thread documentation.

Exact steps for others to reproduce the error

  • Run blender --factory-startup
  • Start playback (space bar)
  • After a bit stop playback
  • Quit Blender
  • Observe the message in the terminal

P.S. It is also not fully clear why audio device is created in this case, as there is no audio in the scene. Ideally the audio sub-system is to be initialized if really needed. But this is a bit of a separate issue from this one. (NOTE: The Sync is set to Play Every Frame, so it is not due to the A/V Sync).

**System Information** Operating system: macOS-14.4.1-arm64-arm-64bit 64 Bits Graphics card: Metal API Apple M2 Ultra 1.2 **Blender Version** Broken: version: 4.2.0 Alpha, branch: main, commit date: 2024-04-23 21:08, hash: `ce768d43a121` Worked: Prior 43307b667d9 **Short description of error** Blender aborts on exit due to incorrect deinitialization in the `OpenCloseDevice()`. Note the STL [documentation](https://en.cppreference.com/w/cpp/thread/thread/%7Ethread) of `std::thread`: If `*this` has an associated thread (`joinable() == true`), `std::terminate()` is called. There is no code which guarantees that `OpenCloseDevice::m_delayed_close_thread` is not joinable upon `~OpenCloseDevice()`, which leads to the termination, as per the `std::thread` documentation. **Exact steps for others to reproduce the error** * Run `blender --factory-startup` * Start playback (space bar) * After a bit stop playback * Quit Blender * Observe the message in the terminal P.S. It is also not fully clear why audio device is created in this case, as there is no audio in the scene. Ideally the audio sub-system is to be initialized if really needed. But this is a bit of a separate issue from this one. (NOTE: The Sync is set to `Play Every Frame`, so it is not due to the A/V Sync).
Sergey Sharybin added the
Status
Needs Triage
Priority
Normal
Type
Report
labels 2024-04-24 11:59:52 +02:00
Member

Confirming issue because I ran into similar issues with a debug builds of Blender earlier this week.

Confirming issue because I ran into similar issues with a debug builds of Blender earlier this week.
Alaska added
Status
Confirmed
Platform
macOS
Module
Core
and removed
Status
Needs Triage
labels 2024-04-24 12:09:39 +02:00

Can reproduce, will check

Can reproduce, will check

Ah looks like the same I ran into also two days ago: #107607 (comment)

Ah looks like the same I ran into also two days ago: https://projects.blender.org/blender/blender/pulls/107607#issuecomment-1174883

I have created PR #121242, but will create also one upstream. I can use some review though, since I had to avoid calling virtual function in destructor, which makes this rather ugly IMO.

I have created PR #121242, but will create also one upstream. I can use some review though, since I had to avoid calling virtual function in destructor, which makes this rather ugly IMO.
Joerg Mueller self-assigned this 2024-05-06 08:33:29 +02:00
Member

Fixed in a5ba4032e0 with help from @iss and @Sergey.

Fixed in a5ba4032e0dd581776704ca1f15a8264578a1f27 with help from @iss and @Sergey.
Blender Bot added
Status
Archived
and removed
Status
Confirmed
labels 2024-05-06 08:35:15 +02:00

@neXyon Thanks for fix, but ... I can't see if your commit was accepted and is currently part of daily build ... if so, the issue persists on my Mac, even with today build.

Thanks for info ... It is really annoying.

@neXyon Thanks for fix, but ... I can't see if your commit was accepted and is currently part of daily build ... if so, the issue persists on my Mac, even with today build. Thanks for info ... It is really annoying.

@FilipMond Can you provide your system info (Help > Save System Info) and crash report to confirm it is the same issue?
This issue was resolved and the commit was linked above.

@FilipMond Can you provide your system info (Help > Save System Info) and crash report to confirm it is the same issue? This issue was resolved and the commit was linked above.

@FilipMond This seems to be different issue - something with python deinitialization. Please create new report

@FilipMond This seems to be different issue - something with python deinitialization. Please create new report

@iss I already created one two weeks ago #121350 ... it was closed by Sergey and merged with this one. Should I still create another one?

@iss I already created one two weeks ago https://projects.blender.org/blender/blender/issues/121350 ... it was closed by Sergey and merged with this one. Should I still create another one?

@FilipMond Yes, do make new one please.

@FilipMond Yes, do make new one please.

Just to be sure, I have double checked, and the trace for core audio issue was

Thread 0 Crashed::  Dispatch queue: com.apple.main-thread
0   libsystem_kernel.dylib        	    0x7ff80c2107a6 __pthread_kill + 10
1   libsystem_pthread.dylib       	    0x7ff80c248f30 pthread_kill + 262
2   libsystem_c.dylib             	    0x7ff80c167aed __abort + 145
3   libsystem_c.dylib             	    0x7ff80c167a5c abort + 141
4   libc++abi.dylib               	    0x7ff80c201c72 abort_message + 241
5   libc++abi.dylib               	    0x7ff80c1f3d3f demangling_terminate_handler() + 47
6   libc++abi.dylib               	    0x7ff80c2010cb std::__terminate(void (*)()) + 6
7   libc++abi.dylib               	    0x7ff80c201070 std::terminate() + 32
8   Blender                       	       0x10afb747b aud::CoreAudioDevice::~CoreAudioDevice() + 139
9   Blender                       	       0x10afb6c1e aud::CoreAudioDevice::~CoreAudioDevice() + 14
10  Blender                       	       0x10af869be aud::DeviceManager::releaseDevice() + 62
11  Blender                       	       0x108324e30 BKE_sound_exit + 16
12  Blender                       	       0x1088e18bc WM_exit_ex(bContext*, bool, bool) + 988
13  Blender                       	       0x1088e128f WM_exit(bContext*, int) + 47
14  Blender                       	       0x1088e14db wm_exit_handler(bContext*, wmEvent const*, void*) + 11
15  Blender                       	       0x1088cf138 wm_handlers_do_intern(bContext*, wmWindow*, wmEvent*, ListBase*) + 3432
16  Blender                       	       0x1088cdda0 wm_handlers_do(bContext*, wmEvent*, ListBase*) + 48
17  Blender                       	       0x1088cd123 wm_event_do_handlers(bContext*) + 2595
18  Blender                       	       0x1088c1a30 WM_main(bContext*) + 32
19  Blender                       	       0x107ecf9e2 main + 866
20  dyld                          	    0x7ff80bec03a6 start + 1942

In your report it is different

Just to be sure, I have double checked, and the trace for core audio issue was ``` Thread 0 Crashed:: Dispatch queue: com.apple.main-thread 0 libsystem_kernel.dylib 0x7ff80c2107a6 __pthread_kill + 10 1 libsystem_pthread.dylib 0x7ff80c248f30 pthread_kill + 262 2 libsystem_c.dylib 0x7ff80c167aed __abort + 145 3 libsystem_c.dylib 0x7ff80c167a5c abort + 141 4 libc++abi.dylib 0x7ff80c201c72 abort_message + 241 5 libc++abi.dylib 0x7ff80c1f3d3f demangling_terminate_handler() + 47 6 libc++abi.dylib 0x7ff80c2010cb std::__terminate(void (*)()) + 6 7 libc++abi.dylib 0x7ff80c201070 std::terminate() + 32 8 Blender 0x10afb747b aud::CoreAudioDevice::~CoreAudioDevice() + 139 9 Blender 0x10afb6c1e aud::CoreAudioDevice::~CoreAudioDevice() + 14 10 Blender 0x10af869be aud::DeviceManager::releaseDevice() + 62 11 Blender 0x108324e30 BKE_sound_exit + 16 12 Blender 0x1088e18bc WM_exit_ex(bContext*, bool, bool) + 988 13 Blender 0x1088e128f WM_exit(bContext*, int) + 47 14 Blender 0x1088e14db wm_exit_handler(bContext*, wmEvent const*, void*) + 11 15 Blender 0x1088cf138 wm_handlers_do_intern(bContext*, wmWindow*, wmEvent*, ListBase*) + 3432 16 Blender 0x1088cdda0 wm_handlers_do(bContext*, wmEvent*, ListBase*) + 48 17 Blender 0x1088cd123 wm_event_do_handlers(bContext*) + 2595 18 Blender 0x1088c1a30 WM_main(bContext*) + 32 19 Blender 0x107ecf9e2 main + 866 20 dyld 0x7ff80bec03a6 start + 1942 ``` In your report it is different
Author
Owner

@FilipMond It's the stack-trace from Piotr which I didn't notice is different from yours, and which was the same exact as this report. It still worth submitting a new bug report, using the latest Blender version from the buidlbot, to ensure we're using the same version, which includes all the known bug-fixes.

If you can also check if the issue happens with the factory startup, that'd also help, as we are unable to reproduce any other crash on exit so far.

@FilipMond It's the stack-trace from Piotr which I didn't notice is different from yours, and which was the same exact as this report. It still worth submitting a new bug report, using the latest Blender version from the buidlbot, to ensure we're using the same version, which includes all the known bug-fixes. If you can also check if the issue happens with the factory startup, that'd also help, as we are unable to reproduce any other crash on exit so far.

@Sergey ... OK reported with daily build and Factory startup ...

BTW my crash report above (in this thread) was also made by 4.2 with Factory startup ... I just feel it personally since none of Mac user didnt complain yet, hm ... :)

@Sergey ... OK [reported ](https://projects.blender.org/blender/blender/issues/122227) with daily build and Factory startup ... BTW my crash report above (in this thread) was also made by 4.2 with Factory startup ... I just feel it personally since none of Mac user didnt complain yet, hm ... :)
Author
Owner

@FilipMond Thanks! Lets move investigation to the new report!

@FilipMond Thanks! Lets move investigation to the new report!
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Asset Browser Project
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
6 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#121015
No description provided.