Sculpt Mode Project TODO #73448

Closed
opened 2020-01-28 04:34:25 +01:00 by Pablo Dobarro · 22 comments
Member

This task keeps track of the tasks that need to be tackled to consider the Sculpt Mode finished and ready to use in production.

After completing all these tasks, Blender should have a perfectly functional sculpting workflow for creating stylized sculpts.

Note that some other task and features not listed here can be development in the meantime or in the future. This is a list of the minimum functionality Blender should provide to avoid users running into obvious software limitation during their workflow.

This list is only focused on stylized sculpting. Supporting high poly sculpting to this same level of feature polishing is a much bigger project that needs a completely different set of features to be designed and developed (most of them related to texture projection options and brush/alpha management currently missing in Blender and limited by the deprecated Texture datablock).

Not Possible Workaround

These task are related to features that are not working and they don’t have any possible workaround or alternative in Blender.

  • #73317 Multires Detail Propagation
  • #73317 Multires Rebuild/Subdivide levels

Not Functional Workaround

These task are about features that are currently available in some form, but due to some design/performance issues they are not usable for a sculpting workflow:

  • #71951 Sculpt Mode with Multiple Objects: Update Keymap, Multithreaded PBVH building, cache the SculptSession, update Overlays...
  • #71946 D5975 Sculpt Vertex Colors: MVertCol Layer, Paint Brush, Remesher, Color Filter, Multires support.
  • #71946 D6070 Visibility Management: Something that provides the same functionality as sculpt Face Groups, Multires support.
  • Brush Management: 2.83 will include brush tool updates that will require more than a preset per tool. This may require a global brush palette to make the system usable for new users (they don’t know which tool correspond to each brush).
  • D6269 Delay Viewport Updates: Fix the viewport lag after a full mesh update operation.
  • #71759 Undo brush properties bug in sculpt and paint modes

Incomplete Tools

These features are related to a certain tool. They limit the usability and the scope of a particular tool, but they do not affect the sculpting workflow as a whole.

  • D6705 Edge Automasking
  • D7059 Topological Falloff
  • D6156 Texture Mesh Filter
  • D6449 Edit Voxel Size Operator (or fix the PBVH rebuild bug)
  • Transform tool: Orientations and view gizmo during transform.
  • Transform tool: Move pivot position independently.

Missing Features

These features are currently not optimal to be used in Sculpt Mode, but we have other functional features in Blender to do the same thing.

This task keeps track of the tasks that need to be tackled to consider the Sculpt Mode finished and ready to use in production. After completing all these tasks, Blender should have a perfectly functional sculpting workflow for creating stylized sculpts. Note that some other task and features not listed here can be development in the meantime or in the future. This is a list of the minimum functionality Blender should provide to avoid users running into obvious software limitation during their workflow. This list is only focused on stylized sculpting. Supporting high poly sculpting to this same level of feature polishing is a much bigger project that needs a completely different set of features to be designed and developed (most of them related to texture projection options and brush/alpha management currently missing in Blender and limited by the deprecated Texture datablock). ## Not Possible Workaround These task are related to features that are not working and they don’t have any possible workaround or alternative in Blender. - #73317 Multires Detail Propagation - #73317 Multires Rebuild/Subdivide levels ## Not Functional Workaround These task are about features that are currently available in some form, but due to some design/performance issues they are not usable for a sculpting workflow: - #71951 Sculpt Mode with Multiple Objects: Update Keymap, Multithreaded PBVH building, cache the SculptSession, update Overlays... - #71946 [D5975](https://archive.blender.org/developer/D5975) Sculpt Vertex Colors: MVertCol Layer, Paint Brush, Remesher, Color Filter, Multires support. - #71946 [D6070](https://archive.blender.org/developer/D6070) Visibility Management: Something that provides the same functionality as sculpt Face Groups, Multires support. - Brush Management: 2.83 will include brush tool updates that will require more than a preset per tool. This may require a global brush palette to make the system usable for new users (they don’t know which tool correspond to each brush). - [D6269](https://archive.blender.org/developer/D6269) Delay Viewport Updates: Fix the viewport lag after a full mesh update operation. - #71759 Undo brush properties bug in sculpt and paint modes ## Incomplete Tools These features are related to a certain tool. They limit the usability and the scope of a particular tool, but they do not affect the sculpting workflow as a whole. - [D6705](https://archive.blender.org/developer/D6705) Edge Automasking - [D7059](https://archive.blender.org/developer/D7059) Topological Falloff - [D6156](https://archive.blender.org/developer/D6156) Texture Mesh Filter - [D6449](https://archive.blender.org/developer/D6449) Edit Voxel Size Operator (or fix the PBVH rebuild bug) - Transform tool: Orientations and view gizmo during transform. - Transform tool: Move pivot position independently. ## Missing Features These features are currently not optimal to be used in Sculpt Mode, but we have other functional features in Blender to do the same thing. - [D6158](https://archive.blender.org/developer/D6158) Quadriflow Guides - #71950 Trimming Tools
Author
Member

Added subscriber: @PabloDobarro

Added subscriber: @PabloDobarro

Changed status from 'Needs Triage' to: 'Confirmed'

Changed status from 'Needs Triage' to: 'Confirmed'
Member

Added subscriber: @JulienKaspar

Added subscriber: @JulienKaspar

Added subscriber: @AlbertoVelazquez

Added subscriber: @AlbertoVelazquez

Added subscriber: @0o00o0oo

Added subscriber: @0o00o0oo

Added subscriber: @unumex-4

Added subscriber: @unumex-4

Added subscriber: @dlc17

Added subscriber: @dlc17

Added subscriber: @Josephbburg

Added subscriber: @Josephbburg

Added subscriber: @lucasfalcao3d

Added subscriber: @lucasfalcao3d

Added subscriber: @Jaydead

Added subscriber: @Jaydead
Member

Added subscriber: @TomMusgrove

Added subscriber: @TomMusgrove

Added subscriber: @Stinaus

Added subscriber: @Stinaus

Added subscriber: @anonym

Added subscriber: @anonym

Added subscriber: @Constantina32

Added subscriber: @Constantina32
Contributor

Added subscriber: @jmztn

Added subscriber: @jmztn

Added subscriber: @TheRedWaxPolice

Added subscriber: @TheRedWaxPolice

Added subscriber: @ckohl_art

Added subscriber: @ckohl_art

Added subscriber: @funksy

Added subscriber: @funksy

Added subscriber: @pauanyu_blender

Added subscriber: @pauanyu_blender

Added subscriber: @brecht

Added subscriber: @brecht

Changed status from 'Confirmed' to: 'Archived'

Changed status from 'Confirmed' to: 'Archived'

Closing outdated planning task.

Closing outdated planning task.
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Asset Browser Project
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
20 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#73448
No description provided.