Potential candidates for corrective releases #83216

Closed
opened 2020-11-30 10:38:08 +01:00 by Dalai Felinto · 25 comments

NOTE: Checked items have already been merged into blender-v2.91-release branch. When adding new items make sure it isn't checked so we know what still needs to be done

List with fixes that could be in 2.91.1

Fixes that could be in 2.91.2

Fixes that could be in 2.91.3

NOTE: Checked items have already been merged into `blender-v2.91-release` branch. When adding new items make sure it isn't checked so we know what still needs to be done List with fixes that could be in 2.91.1 - [x] *[Note, 2.91.1 was skipped in favour of 2.91.2 ](https:*lists.blender.org/pipermail/bf-committers/2021-January/050870.html).// Fixes that could be in 2.91.2 - [x] 20f8130d6f - [x] 898231fdbc - [x] 44f5d99cbf - [x] f9e994d0f4 - [x] e4e7dfc1d8 - [x] c576d65c2f - [x] f3b08af24c - [x] b9eb592133 - [x] 561d9169fe - [x] 97651f428b - [x] d1cedf53fa - [x] c2a01a6c11 - [x] 3d0b65f89b - [x] 2b9eb5eee5 - [x] e035d7301c - [x] cf2ebaf27c - [x] ebd8a703cc - [x] 8d590e4b86 - [x] 7d25139eaf - [x] 4b56c18290 - [x] 967cf303f3 - [x] f0071dfa10 - [x] 691c021679 - [x] f35a38fba7 - [x] 15bb8f9f93 - [x] 2d3f96cace - [x] 08e44b5e3e - [x] d11a87b88c - [x] a3fcbb54f4 - [x] cb2517016b - [x] 9fb32b2b29 - [x] 4c44a5309c - [x] c716b9862a - [x] 5d99199880 - [x] 55c56f1ffb - [x] abbc43e4e4 - [x] ffb6648a97 - [x] 84451f89f5 Fixes that could be in 2.91.3 - [ ] e25f7e33ff - [ ] e9cd3d50a7 - [ ] acc662ea5a - [ ] 216ebe0b73 - [ ] 419c67c851
Author
Owner

Changed status from 'Needs Triage' to: 'Confirmed'

Changed status from 'Needs Triage' to: 'Confirmed'
Author
Owner

Added subscriber: @dfelinto

Added subscriber: @dfelinto

Added subscriber: @Harvester

Added subscriber: @Harvester

Added subscriber: @Slowwkidd

Added subscriber: @Slowwkidd
Member

Added subscriber: @EAW

Added subscriber: @EAW

Added subscriber: @kevindietrich

Added subscriber: @kevindietrich

84451f89f5 should also be considered for backport (discussed here 5c01ecd2bf)

84451f89f5 should also be considered for backport (discussed here 5c01ecd2bf)

Added subscriber: @mano-wii

Added subscriber: @mano-wii

I am surprised that release 2.91 apparently does not have 20f8130d6f (resulting in #83654)
That is a relatively old commit.

In that case, it would be good to check and backport 20f8130d6f, 898231fdbc

I am surprised that release 2.91 apparently does not have 20f8130d6f (resulting in #83654) That is a relatively old commit. In that case, it would be good to check and backport 20f8130d6f, 898231fdbc

Added subscriber: @mont29

Added subscriber: @mont29

In #83216#1074178, @mano-wii wrote:
I am surprised that release 2.91 apparently does not have 20f8130d6f (resulting in #83654)
That is a relatively old commit.

In that case, it would be good to check and backport 20f8130d6f, 898231fdbc

it's developer's responsibility to commit their fix in release branch if/when they think it is safe enough to do so, at least in bcon3 (in bcon4 all commits to release branch must be reviewed and approved by a core team member first).

But we do not do cherry-picking from master into release branch typically. See https://wiki.blender.org/wiki/Process/Release_Cycle

> In #83216#1074178, @mano-wii wrote: > I am surprised that release 2.91 apparently does not have 20f8130d6f (resulting in #83654) > That is a relatively old commit. > > In that case, it would be good to check and backport 20f8130d6f, 898231fdbc it's developer's responsibility to commit their fix in release branch if/when they think it is safe enough to do so, at least in bcon3 (in bcon4 all commits to release branch must be reviewed and approved by a core team member first). But we do not do cherry-picking from master into release branch typically. See https://wiki.blender.org/wiki/Process/Release_Cycle
And also, forgot that link: https://wiki.blender.org/wiki/Process/Using_Stabilizing_Branch
Contributor

Added subscriber: @Raimund58

Added subscriber: @Raimund58
Contributor

I would like to propose {https://developer.blender.org/rB87b19b3aba0c8535d48ad07e2dae2e09373c913a} being back ported because otherwise Cycles is broken for users with special characters in their path to the BLENDER_USER_CONFIG.

I would like to propose {https://developer.blender.org/rB87b19b3aba0c8535d48ad07e2dae2e09373c913a} being back ported because otherwise Cycles is broken for users with special characters in their path to the BLENDER_USER_CONFIG.

Removed subscriber: @Slowwkidd

Removed subscriber: @Slowwkidd
Member

Added subscriber: @StephenLeger

Added subscriber: @StephenLeger
Member

Hi could you consider backport of blender/blender-addons@8ca8233069

Hi could you consider backport of blender/blender-addons@8ca8233069
Member

Added subscriber: @Jeroen-Bakker

Added subscriber: @Jeroen-Bakker

How is it that the versioning has switched directly to 2.91.2? This version numbering is both in the file names (https://download.blender.org/release/Blender2.91/) and in Blender itself (as shown in the splash screen). Probably, this was intentional but, just in case, I let you notice it. Thanks.

How is it that the versioning has switched directly to 2.91.2? This version numbering is both in the file names (https://download.blender.org/release/Blender2.91/) and in Blender itself (as shown in the splash screen). Probably, this was intentional but, just in case, I let you notice it. Thanks.

Added subscriber: @Leroy-Xie

Added subscriber: @Leroy-Xie

Don't have #83027...

Don't have #83027...
Author
Owner

@Leroy-Xie This list is for developers to include commits. Not to raise the awareness or priorities of reported (unfixed) issues.

@Leroy-Xie This list is for developers to include commits. Not to raise the awareness or priorities of reported (unfixed) issues.

Added subscriber: @frispete

Added subscriber: @frispete
Member

Changed status from 'Confirmed' to: 'Resolved'

Changed status from 'Confirmed' to: 'Resolved'
Jeroen Bakker self-assigned this 2021-03-02 10:43:56 +01:00
Member

Closing ticket as there won't be any corrective releases anymore for 2.91. See #85958 (Potential candidates for corrective releases) for 2.92

Closing ticket as there won't be any corrective releases anymore for 2.91. See #85958 (Potential candidates for corrective releases) for 2.92
Thomas Dinges added this to the 2.91 milestone 2023-02-08 16:20:07 +01:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser Project (Legacy)
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
12 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#83216
No description provided.