Alt+Click to select overlapping bones #85796

Closed
opened 2021-02-19 16:59:15 +01:00 by Demeter Dzadik · 8 comments

A revival of #83299, as approved by @ZedDB in #animation-module.

Current situation

In current Blender, you can Alt+SelectClick (whether you're on left or right click select) in object mode, and be prompted with a list of all objects which are underneath your mouse cursor, so you can easily select one from the list. This is often much nicer than repeatedly clicking to cycle between said objects, until you land on the correct one.

A small odd thing I noticed is that it seems to list the overlapping objects in reverse alphabetical order, I wonder if there's a reason for that or if it's just a bug.

This operator works in pose mode, but it's still listing overlapping objects instead of pose bones. The operator doesn't work in armature edit mode.

Goals

Ideally, the operator would work in both modes to select pose or edit bones.
I can even see some people who might want to set up their keymap so that click-selecting in pose or edit mode always uses this feature, without even having to hold Alt. If this was possible, that would be a nice bonus.

Use cases

Here is an example of a real bird rig currently used in production, where you can't even see the bird due to the amount of overlapping bones: image.png

This is sort of an extreme case, sure, but really you can go into any production rig and see why this selection method would be extremely useful when debugging and tweaking rig helper bones.

I think it would also be useful for animators in some cases, since even control bones can get a bit dense sometimes.

A revival of #83299, as approved by @ZedDB in [#animation-module](https://blender.chat/channel/animation-module). ### Current situation In current Blender, you can Alt+SelectClick (whether you're on left or right click select) in object mode, and be prompted with a list of all objects which are underneath your mouse cursor, so you can easily select one from the list. This is often much nicer than repeatedly clicking to cycle between said objects, until you land on the correct one. A small odd thing I noticed is that it seems to list the overlapping objects in reverse alphabetical order, I wonder if there's a reason for that or if it's just a bug. This operator works in pose mode, but it's still listing overlapping objects instead of pose bones. The operator doesn't work in armature edit mode. ### Goals Ideally, the operator would work in both modes to select pose or edit bones. I can even see some people who might want to set up their keymap so that click-selecting in pose or edit mode always uses this feature, without even having to hold Alt. If this was possible, that would be a nice bonus. ### Use cases Here is an example of a real bird rig currently used in production, where you can't even see the bird due to the amount of overlapping bones: ![image.png](https://archive.blender.org/developer/F9818137/image.png) This is sort of an extreme case, sure, but really you can go into any production rig and see why this selection method would be extremely useful when debugging and tweaking rig helper bones. I think it would also be useful for animators in some cases, since even control bones can get a bit dense sometimes.
Poster
Collaborator

Added subscribers: @ZedDB, @Mets

Added subscribers: @ZedDB, @Mets
Sebastian Parborg was assigned by Demeter Dzadik 2021-02-19 17:00:35 +01:00

Added subscriber: @LucianoMunoz

Added subscriber: @LucianoMunoz

Yes!, thank you @Mets for creating this task it's something that has been in the back of my head forever :)

Yes!, thank you @Mets for creating this task it's something that has been in the back of my head forever :)

Changed status from 'Needs Triage' to: 'Confirmed'

Changed status from 'Needs Triage' to: 'Confirmed'

Added subscriber: @JerBot

Added subscriber: @JerBot

I've posted a WIP patch: D10570

I've posted a WIP patch: [D10570](https://archive.blender.org/developer/D10570)

This issue was referenced by 5e77ff79cc

This issue was referenced by 5e77ff79ccdaffb2df4d54c97f17359c017c9b85

Changed status from 'Confirmed' to: 'Resolved'

Changed status from 'Confirmed' to: 'Resolved'
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser
Interest
Asset Browser Project Overview
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest: Wayland
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
5 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#85796
There is no content yet.