Grease pencil scale issue #99117

Open
opened 2022-06-23 20:26:16 +02:00 by ezra holland · 15 comments

System Information
Operating system: Windows-10-10.0.22000-SP0 64 Bits
Graphics card: NVIDIA GeForce RTX 3090/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 511.65

Blender Version
Broken: version: 3.2.0, branch: master, commit date: 2022-06-08 10:22, hash: e05e1e3691

Short description of error
Grease pencil seems to deteriorate as the scale of a camera increases

Exact steps for others to reproduce the error
In the attached file I created a door object with a central thinner panel. I then created an orthographic camera at ortho scale 1 in plan view and set the near clipping plan to about the middle of the door in the Z axis. I added a Grease pencil scene Lineart object an placed it in it's own collection to aid turning it on and off and set the style thickness to 1 in the modifier tab. The resulting lineart works fine. I then duplicated the camera and changed its orthographic scale to 2 which also works fine. I repeated this at orthographic scale 3 and again at 4 where the resulting lineart starts to break down. at orthographic scale 20 the issue is very apparent. If I am working on a large scale scene I obviously need to have my orthographic scale high. Please advise if there is a way of increasing the orthographic scale without losing the line art quality.
Thanks
Greasepencil_scale_bug01.blend
camera ortho scale 4.png

camera ortho scale 20.png

**System Information** Operating system: Windows-10-10.0.22000-SP0 64 Bits Graphics card: NVIDIA GeForce RTX 3090/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 511.65 **Blender Version** Broken: version: 3.2.0, branch: master, commit date: 2022-06-08 10:22, hash: `e05e1e3691` **Short description of error** Grease pencil seems to deteriorate as the scale of a camera increases **Exact steps for others to reproduce the error** In the attached file I created a door object with a central thinner panel. I then created an orthographic camera at ortho scale 1 in plan view and set the near clipping plan to about the middle of the door in the Z axis. I added a Grease pencil scene Lineart object an placed it in it's own collection to aid turning it on and off and set the style thickness to 1 in the modifier tab. The resulting lineart works fine. I then duplicated the camera and changed its orthographic scale to 2 which also works fine. I repeated this at orthographic scale 3 and again at 4 where the resulting lineart starts to break down. at orthographic scale 20 the issue is very apparent. If I am working on a large scale scene I obviously need to have my orthographic scale high. Please advise if there is a way of increasing the orthographic scale without losing the line art quality. Thanks [Greasepencil_scale_bug01.blend](https://archive.blender.org/developer/F13221791/Greasepencil_scale_bug01.blend) ![camera ortho scale 4.png](https://archive.blender.org/developer/F13221796/camera_ortho_scale_4.png) ![camera ortho scale 20.png](https://archive.blender.org/developer/F13221795/camera_ortho_scale_20.png)
Author

Added subscriber: @ezraholland

Added subscriber: @ezraholland

Added subscribers: @ChengduLittleA, @iss

Added subscribers: @ChengduLittleA, @iss

I am not able to reproduce this issue.

@ChengduLittleA can you reproduce?

I am not able to reproduce this issue. @ChengduLittleA can you reproduce?
Author

do you need me to try to explain the issue more clearly? Essentially orthographic cameras with a small orthographic scale produce better lineart results than ones with larger scales. It may be easier to see what is going on when we refer to these two images of the lineart at orthographic scales 20 and 4. The diagonal lines in the Z axis become more extreme as the scale increases and I guess at some point they take precedent over the x y axis lines. Hope this explains what I found a little more clearly.
Thanks
Ezra

{F13222402}

camera ortho scale 4_3d view.png

do you need me to try to explain the issue more clearly? Essentially orthographic cameras with a small orthographic scale produce better lineart results than ones with larger scales. It may be easier to see what is going on when we refer to these two images of the lineart at orthographic scales 20 and 4. The diagonal lines in the Z axis become more extreme as the scale increases and I guess at some point they take precedent over the x y axis lines. Hope this explains what I found a little more clearly. Thanks Ezra ``` {F13222402} ``` ![camera ortho scale 4_3d view.png](https://archive.blender.org/developer/F13222401/camera_ortho_scale_4_3d_view.png)
Author

here is an example using a more complex faucet object at orthographic scales 1,4 and 20{F13222424}

faucet top orth scale 20.png

faucet top orth scale 4.png

here is an example using a more complex faucet object at orthographic scales 1,4 and 20{[F13222424](https://archive.blender.org/developer/F13222424/faucet_top_ortho_scale_1.png)} ![faucet top orth scale 20.png](https://archive.blender.org/developer/F13222423/faucet_top_orth_scale_20.png) ![faucet top orth scale 4.png](https://archive.blender.org/developer/F13222422/faucet_top_orth_scale_4.png)
YimingWu self-assigned this 2022-06-24 04:00:49 +02:00
Member

I'll take a look :)

I'll take a look :)
Member

Hi @ezraholland ! You does have chaining value tuned quite high. If you tune that value to zero and also the smooth tolerance to zero as well, then it works alright :)

图片.png

Hi @ezraholland ! You does have chaining value tuned quite high. If you tune that value to zero and also the smooth tolerance to zero as well, then it works alright :) ![图片.png](https://archive.blender.org/developer/F13222532/图片.png)
Member

Added subscriber: @PratikPB2123

Added subscriber: @PratikPB2123
Member

Changed status from 'Needs Triage' to: 'Needs Developer To Reproduce'

Changed status from 'Needs Triage' to: 'Needs Developer To Reproduce'
Member

Issue is not particularly replicable with orthographic camera. I can even repro this in perspective mode with less focal length value
This issue is happening due to smooth tolerance. Which I think is same as the other report #95740 (Line Art errors when rendering small details)
@ChengduLittleA, can you verify?

Issue is not particularly replicable with orthographic camera. I can even repro this in perspective mode with less focal length value This issue is happening due to smooth tolerance. Which I think is same as the other report #95740 (Line Art errors when rendering small details) @ChengduLittleA, can you verify?
Member

Changed status from 'Needs Developer To Reproduce' to: 'Confirmed'

Changed status from 'Needs Developer To Reproduce' to: 'Confirmed'
Member

Yes, I can verify it's the smooth tolerance and chaining value being problematic. I think we may need to restore that default value to zero to avoid confusions? Because the user may not notice that functionality. I'll make a patch for this thing.

I do find a little bit of wrong occlusion in some very tiny details, those are not related to chaining or smooth tolerance, I'll use this file to further check the occlusion issue. I think we may leave it in Confirmed state and I'll be able to see to it further down the line?

Yes, I can verify it's the smooth tolerance and chaining value being problematic. I think we may need to restore that default value to zero to avoid confusions? Because the user may not notice that functionality. I'll make a patch for this thing. I do find a little bit of wrong occlusion in some very tiny details, those are not related to chaining or smooth tolerance, I'll use this file to further check the occlusion issue. I think we may leave it in Confirmed state and I'll be able to see to it further down the line?
Author

Thanks very much for explaining this. I also found that turning force backface culling on works well for objects that are not clipped by the camera clipping planes as as can be seen in the attached images with the faucet object on the left, but not for the door object on the right which is clipped by the camera. As I commonly have objects that are clipped and objects that aren't I'm guessing I'd need to have multiple lineart modifiers to achieve my desired result?
Thanks again

{F13225442}

backface culling on.png

Thanks very much for explaining this. I also found that turning force backface culling on works well for objects that are not clipped by the camera clipping planes as as can be seen in the attached images with the faucet object on the left, but not for the door object on the right which is clipped by the camera. As I commonly have objects that are clipped and objects that aren't I'm guessing I'd need to have multiple lineart modifiers to achieve my desired result? Thanks again ``` {F13225442} ``` ![backface culling on.png](https://archive.blender.org/developer/F13225441/backface_culling_on.png)
Author

I forgot to mention the small lines appearing on the end of the faucet objects spout where it curves away from the camera. Any Idea what I could do to prevent these from appearing?Screenshot (48).png

I forgot to mention the small lines appearing on the end of the faucet objects spout where it curves away from the camera. Any Idea what I could do to prevent these from appearing?![Screenshot (48).png](https://archive.blender.org/developer/F13225573/Screenshot__48_.png)
Member

@ezraholland if you have to clip, try to use boolean, or enable "clipped boundaries"

Here I even had more of these small lines appearing that yours. Best way to avoid them is not to use exact angles for now....

Also, check your topology, you seem to have edges that connected to more than 2 faces in that faucet as well...

@ezraholland if you have to clip, try to use boolean, or enable "clipped boundaries" Here I even had more of these small lines appearing that yours. Best way to avoid them is not to use exact angles for now.... Also, check your topology, you seem to have edges that connected to more than 2 faces in that faucet as well...
Sergey Sharybin added
Module
Grease Pencil
and removed
Module
VFX & Video
labels 2023-02-13 18:08:11 +01:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Asset Browser Project
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
4 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#99117
No description provided.