HIP Vega system freeze #99585

Closed
opened 2022-07-10 13:42:03 +02:00 by bruno · 21 comments

System Information
Operating system: Windows-10-10.0.19044-SP0 64 Bits
Graphics card: Radeon RX Vega ATI Technologies Inc. 4.5.14800 Core Profile Context 22.4.2 30.0.15021.7000

Blender Version
Broken: version: 3.3.0 Alpha, branch: master, commit date: 2022-06-28 22:57, hash: c0e4532331

Short description of error
The whole system freezes when rendering or baking after a viewport render is complete on scenes that need more video memory than available.

Exact steps for others to reproduce the error

Render a image

After that, system freezes, screen goes black and GPU goes idle (I can notice that because its LED usage indicators and fan speed go to minimum).
I can't reproduce this on simpler scenes like BMW and Classroom, so I think it might be related to video memory.

**System Information** Operating system: Windows-10-10.0.19044-SP0 64 Bits Graphics card: Radeon RX Vega ATI Technologies Inc. 4.5.14800 Core Profile Context 22.4.2 30.0.15021.7000 **Blender Version** Broken: version: 3.3.0 Alpha, branch: master, commit date: 2022-06-28 22:57, hash: `c0e4532331` **Short description of error** The whole system freezes when rendering or baking after a viewport render is complete on scenes that need more video memory than available. **Exact steps for others to reproduce the error** - Open a complex scene, like Junk Shop: https://cloud.blender.org/p/gallery/5dd6d7044441651fa3decb56 - Change viewport mode to rendered and wait for it to finish # Render a image After that, system freezes, screen goes black and GPU goes idle (I can notice that because its LED usage indicators and fan speed go to minimum). I can't reproduce this on simpler scenes like BMW and Classroom, so I think it might be related to video memory.
Author

Added subscriber: @brunocb

Added subscriber: @brunocb
Member

Added subscriber: @PratikPB2123

Added subscriber: @PratikPB2123
Member

Changed status from 'Needs Triage' to: 'Needs User Info'

Changed status from 'Needs Triage' to: 'Needs User Info'
Member

Please open Blender's installation directory and double click on the blender_debug_gpu.cmd. This will start Blender in debug mode and create log files. Try to reproduce the error again. Once it crashes or you close Blender manually the Windows Explorer should open and show you up to two files, a debug log and the system information. Add them to your bug report by clicking on the upload button as shown in the screenshot below or via drag and drop. Please also upload the crash log located in C:\Users\[your username]\AppData\Local\Temp\[project name].crash.txt (or simply type %TEMP% into the path bar of the Windows Explorer).2019_12_04_upload_icon_developer_blender_org.png

Please open Blender's installation directory and double click on the `blender_debug_gpu.cmd`. This will start Blender in debug mode and create log files. Try to reproduce the error again. Once it crashes or you close Blender manually the Windows Explorer should open and show you up to two files, a debug log and the system information. Add them to your bug report by clicking on the upload button as shown in the screenshot below or via drag and drop. Please also upload the crash log located in `C:\Users\[your username]\AppData\Local\Temp\[project name].crash.txt` (or simply type `%TEMP%` into the path bar of the Windows Explorer).![2019_12_04_upload_icon_developer_blender_org.png](https://archive.blender.org/developer/F8190038/2019_12_04_upload_icon_developer_blender_org.png)
Author

After some time searching, I found these on "%temp%\blender\debug_logs".
blender_system_info.txt

blender_debug_output.txt

I should have said before but windows can't recover from this and I have to manually restart the computer.

After some time searching, I found these on "%temp%\blender\debug_logs". [blender_system_info.txt](https://archive.blender.org/developer/F13286189/blender_system_info.txt) [blender_debug_output.txt](https://archive.blender.org/developer/F13286190/blender_debug_output.txt) I should have said before but windows can't recover from this and I have to manually restart the computer.
Member

Thanks. Warnings which are probably related to drivers are only printed in the log files.
Please observe the memory usage when rendering the scene (might be out of memory case)

How much VRAM, RAM you've?

Thanks. Warnings which are probably related to drivers are only printed in the log files. Please observe the memory usage when rendering the scene (might be out of memory case) How much VRAM, RAM you've?
Author

System:
RAM: 32GB
VRAM: 8GB

Peak memory use when rendering:
RAM: 20GB
VRAM: 8GB

On viewport:
RAM: 16GB
VRAM: 8GB

I noticed that viewport doesn't free the memory after rendering is complete while image rendering does.

System: RAM: 32GB VRAM: 8GB Peak memory use when rendering: RAM: 20GB VRAM: 8GB On viewport: RAM: 16GB VRAM: 8GB I noticed that viewport doesn't free the memory after rendering is complete while image rendering does.
Member

Changed status from 'Needs User Info' to: 'Needs Triage'

Changed status from 'Needs User Info' to: 'Needs Triage'
Member

Added subscriber: @OmarEmaraDev

Added subscriber: @OmarEmaraDev
Member

Changed status from 'Needs Triage' to: 'Needs User Info'

Changed status from 'Needs Triage' to: 'Needs User Info'
Member

Does RAM usage ever get to 100% in your case? This seems like your system is memory swapping, which can naturally cause freezing.
Does pressing Windows + Ctrl + Shift + B during the freezing restore your visuals?
Do you see any relevant errors in the Windows Event Viewer after regaining control of your system or rebooting?

Does RAM usage ever get to 100% in your case? This seems like your system is memory swapping, which can naturally cause freezing. Does pressing Windows + Ctrl + Shift + B during the freezing restore your visuals? Do you see any relevant errors in the Windows Event Viewer after regaining control of your system or rebooting?
Author

Does RAM usage ever get to 100% in your case?

Not necessarily. I have tested with other programs running, when it would hit 100% and start swapping, and also tested with blender alone, when it wouldn't hit above 80%.

Does pressing Windows + Ctrl + Shift + B during the freezing restore your visuals?

No, keyboard and mouse would stop working.

Do you see any relevant errors in the Windows Event Viewer

No.


I have made some changes on my system and now it doesn't freeze, blender just crashes.
I updated win10 some times, updated AMD driver, got an extra gpu, got win11 on another drive, but I'm not sure what changed the error.

When rendering the image, it now shows a black image just before crashing.

> Does RAM usage ever get to 100% in your case? Not necessarily. I have tested with other programs running, when it would hit 100% and start swapping, and also tested with blender alone, when it wouldn't hit above 80%. > Does pressing Windows + Ctrl + Shift + B during the freezing restore your visuals? No, keyboard and mouse would stop working. > Do you see any relevant errors in the Windows Event Viewer No. ___ I have made some changes on my system and now it doesn't freeze, blender just crashes. I updated win10 some times, updated AMD driver, got an extra gpu, got win11 on another drive, but I'm not sure what changed the error. * Windows 10 [blender_system_info.txt](https://archive.blender.org/developer/F13335564/blender_system_info.txt) [blender_debug_output.txt](https://archive.blender.org/developer/F13335566/blender_debug_output.txt) [Junk Shop.crash.txt](https://archive.blender.org/developer/F13335565/Junk_Shop.crash.txt) * Windows 11 [blender_system_info.txt](https://archive.blender.org/developer/F13335567/blender_system_info.txt) [blender_debug_output.txt](https://archive.blender.org/developer/F13335568/blender_debug_output.txt) [Junk Shop.crash.txt](https://archive.blender.org/developer/F13335569/Junk_Shop.crash.txt) When rendering the image, it now shows a black image just before crashing.
Member

Changed status from 'Needs User Info' to: 'Needs Triage'

Changed status from 'Needs User Info' to: 'Needs Triage'
Member
Stack trace:
blender.exe         :0x00007FF6C0FD3AB0  MEM_guarded_freeN
blender.exe         :0x00007FF6BD17FA30  ccl::device_memory::host_free
blender.exe         :0x00007FF6BD16E300  ccl::HIPDevice::~HIPDevice
blender.exe         :0x00007FF6BD16E4B0  ccl::HIPDevice::`vector deleting destructor'
blender.exe         :0x00007FF6BD665110  ccl::Session::~Session
blender.exe         :0x00007FF6BD0F7EE0  ccl::BlenderSession::free_session
blender.exe         :0x00007FF6BD0F5540  ccl::BlenderSession::~BlenderSession
blender.exe         :0x00007FF6BD0EFD80  ccl::free_func
python310.dll       :0x00007FF82B73E1C0  PyCFunction_GetFlags
python310.dll       :0x00007FF82B806D50  PyOS_URandomNonblock
python310.dll       :0x00007FF82B80F000  PyEval_GetFuncDesc
python310.dll       :0x00007FF82B8088F0  PyEval_EvalFrameDefault
python310.dll       :0x00007FF82B8088F0  PyEval_EvalFrameDefault
python310.dll       :0x00007FF82B6FA280  PyFunction_Vectorcall
python310.dll       :0x00007FF82B806D50  PyOS_URandomNonblock
python310.dll       :0x00007FF82B80F000  PyEval_GetFuncDesc
python310.dll       :0x00007FF82B8088F0  PyEval_EvalFrameDefault
python310.dll       :0x00007FF82B8088F0  PyEval_EvalFrameDefault
python310.dll       :0x00007FF82B6FA280  PyFunction_Vectorcall
python310.dll       :0x00007FF82B758F50  PyTuple_Resize
python310.dll       :0x00007FF82B763FD0  PyType_Ready
python310.dll       :0x00007FF82B741B80  PyObject_CallFinalizerFromDealloc
python310.dll       :0x00007FF82B75BE70  PyType_GenericNew
blender.exe         :0x00007FF6BC3B2180  BPY_DECREF_RNA_INVALIDATE
blender.exe         :0x00007FF6BCBC3710  RE_engine_render
blender.exe         :0x00007FF6BCBCBAD0  do_render_engine
blender.exe         :0x00007FF6BCBCB4F0  do_render_compositor
blender.exe         :0x00007FF6BCBCBB40  do_render_full_pipeline
blender.exe         :0x00007FF6BCBC93A0  RE_RenderFrame
blender.exe         :0x00007FF6BD0E3E90  render_startjob
blender.exe         :0x00007FF6BC00CE30  do_job_thread
blender.exe         :0x00007FF6C124FC60  _ptw32_threadStart
ucrtbase.dll        :0x00007FF89A176BB0  recalloc
KERNEL32.DLL        :0x00007FF89BDD54D0  BaseThreadInitThunk
ntdll.dll           :0x00007FF89CBC4830  RtlUserThreadStart
``` Stack trace: blender.exe :0x00007FF6C0FD3AB0 MEM_guarded_freeN blender.exe :0x00007FF6BD17FA30 ccl::device_memory::host_free blender.exe :0x00007FF6BD16E300 ccl::HIPDevice::~HIPDevice blender.exe :0x00007FF6BD16E4B0 ccl::HIPDevice::`vector deleting destructor' blender.exe :0x00007FF6BD665110 ccl::Session::~Session blender.exe :0x00007FF6BD0F7EE0 ccl::BlenderSession::free_session blender.exe :0x00007FF6BD0F5540 ccl::BlenderSession::~BlenderSession blender.exe :0x00007FF6BD0EFD80 ccl::free_func python310.dll :0x00007FF82B73E1C0 PyCFunction_GetFlags python310.dll :0x00007FF82B806D50 PyOS_URandomNonblock python310.dll :0x00007FF82B80F000 PyEval_GetFuncDesc python310.dll :0x00007FF82B8088F0 PyEval_EvalFrameDefault python310.dll :0x00007FF82B8088F0 PyEval_EvalFrameDefault python310.dll :0x00007FF82B6FA280 PyFunction_Vectorcall python310.dll :0x00007FF82B806D50 PyOS_URandomNonblock python310.dll :0x00007FF82B80F000 PyEval_GetFuncDesc python310.dll :0x00007FF82B8088F0 PyEval_EvalFrameDefault python310.dll :0x00007FF82B8088F0 PyEval_EvalFrameDefault python310.dll :0x00007FF82B6FA280 PyFunction_Vectorcall python310.dll :0x00007FF82B758F50 PyTuple_Resize python310.dll :0x00007FF82B763FD0 PyType_Ready python310.dll :0x00007FF82B741B80 PyObject_CallFinalizerFromDealloc python310.dll :0x00007FF82B75BE70 PyType_GenericNew blender.exe :0x00007FF6BC3B2180 BPY_DECREF_RNA_INVALIDATE blender.exe :0x00007FF6BCBC3710 RE_engine_render blender.exe :0x00007FF6BCBCBAD0 do_render_engine blender.exe :0x00007FF6BCBCB4F0 do_render_compositor blender.exe :0x00007FF6BCBCBB40 do_render_full_pipeline blender.exe :0x00007FF6BCBC93A0 RE_RenderFrame blender.exe :0x00007FF6BD0E3E90 render_startjob blender.exe :0x00007FF6BC00CE30 do_job_thread blender.exe :0x00007FF6C124FC60 _ptw32_threadStart ucrtbase.dll :0x00007FF89A176BB0 recalloc KERNEL32.DLL :0x00007FF89BDD54D0 BaseThreadInitThunk ntdll.dll :0x00007FF89CBC4830 RtlUserThreadStart ```
Member

HI, does it still crash in latest builds?: https://builder.blender.org/download/daily/

HI, does it still crash in latest builds?: https://builder.blender.org/download/daily/
Member

Changed status from 'Needs Triage' to: 'Needs User Info'

Changed status from 'Needs Triage' to: 'Needs User Info'
Philipp Oeser removed the
Interest
Render & Cycles
label 2023-02-09 14:04:14 +01:00
Author

Hi, Blender isn't detecting my card on daily build 3.5.0 d82ffb9787 (2024-02-01)

image

Hi, Blender isn't detecting my card on daily build 3.5.0 d82ffb9787c3 (2024-02-01) ![image](/attachments/cbaa39e4-8fa6-429e-989e-8d75faa3d333)
Member

Hi, Blender isn't detecting my card on daily build 3.5.0

I think this is due to #104786

> Hi, Blender isn't detecting my card on daily build 3.5.0 I think this is due to #104786
Member

Blender isn't detecting my card on daily build 3.5.0

Hi, is this still an issue? (sorry for less attention)

> Blender isn't detecting my card on daily build 3.5.0 Hi, is this still an issue? (sorry for less attention)
Author

Instead of crashing it shows "System is out of GPU memory".
Then, changing viewport back to solid allows F12 to render normally.

Instead of crashing it shows "System is out of GPU memory". Then, changing viewport back to solid allows F12 to render normally.
Member

Looks like issue has changed over the time.
@brunocb , please open a new report for "out of memory" case.
Closing this for now.

Looks like issue has changed over the time. @brunocb , please open a new report for "out of memory" case. Closing this for now.
Blender Bot added
Status
Archived
and removed
Status
Needs Information from User
labels 2023-07-20 12:53:34 +02:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser
Interest
Asset Browser Project Overview
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
3 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#99585
No description provided.