transparent background #104035

Closed
opened 2023-01-20 21:49:20 +01:00 by Laurent Guenery · 13 comments

System Information
Operating system: Linux-5.15.0-58-generic-x86_64-with-glibc2.35 64 Bits
Graphics card: NV94 nouveau 3.3 (Core Profile) Mesa 22.0.5

Blender Version
Broken: version: 3.4.1, branch: blender-v3.4-release, commit date: 2022-12-19 17:00, hash: 55485cb379
Worked: version 3-3-2 LTS data 2022-12-06 18:19 hash bf24652e38

Short description of error
No gray background on the working window but a transparent background
image.png

**System Information** Operating system: Linux-5.15.0-58-generic-x86_64-with-glibc2.35 64 Bits Graphics card: NV94 nouveau 3.3 (Core Profile) Mesa 22.0.5 **Blender Version** Broken: version: 3.4.1, branch: blender-v3.4-release, commit date: 2022-12-19 17:00, hash: `55485cb379` Worked: version 3-3-2 LTS data 2022-12-06 18:19 hash bf24652e38a2 **Short description of error** No gray background on the working window but a transparent background ![image.png](https://archive.blender.org/developer/F14180023/image.png)

Added subscriber: @Laurent-1

Added subscriber: @Laurent-1
Member

Added subscribers: @sanzoghenzo, @PratikPB2123

Added subscribers: @sanzoghenzo, @PratikPB2123
Member

Changed status from 'Needs Triage' to: 'Needs User Info'

Changed status from 'Needs Triage' to: 'Needs User Info'
Member

In #102994#1467014, @sanzoghenzo wrote:
hi, I'm using blender 3.4.0 on Fedora 37 on an XPS 15 9650 with Nvidia Optimus/Intel grahics. The issue shows up when using the Nouveau drivers, and disappears if I start blender with the intel graphics card.
UPDATE: installing nvidia drivers fixes the issue.

Hi, thanks for the report. As said in the comment, installing Nvidia drivers solves the issue. Can you try that?

> In #102994#1467014, @sanzoghenzo wrote: > hi, I'm using blender 3.4.0 on Fedora 37 on an XPS 15 9650 with Nvidia Optimus/Intel grahics. The issue shows up when using the Nouveau drivers, and disappears if I start blender with the intel graphics card. > UPDATE: installing nvidia drivers fixes the issue. Hi, thanks for the report. As said in the comment, installing Nvidia drivers solves the issue. Can you try that?

Nvidia drivers not fix this issus, and now after video drivers update a new problem with menu font what's the solution ?

Nvidia drivers not fix this issus, and now after video drivers update a new problem with menu font what's the solution ?
Pratik Borhade added
Status
Needs Triage
and removed
Status
Needs Information from User
labels 2023-02-16 16:58:54 +01:00
Member

Hi, did you check this with official Nvidia drivers?
Please also upload system-info file: Help > Save System Info

Hi, did you check this with official Nvidia drivers? Please also upload system-info file: `Help > Save System Info`
Pratik Borhade added
Status
Needs Information from User
and removed
Status
Needs Triage
labels 2023-03-03 11:40:45 +01:00

HI Patrick
Yes but I a kernel error occur, but after new Linux generic driver install it's OK ! It seem that no Nvidia driver needs. I don't know why.

HI Patrick Yes but I a kernel error occur, but after new Linux generic driver install it's OK ! It seem that no Nvidia driver needs. I don't know why.

Hi Patrick
The problem reappeared after installing fuse-emulator-gtk and fuse-emulator-sdl. I need it for the CURA slicer for my 3D printer

Hi Patrick The problem reappeared after installing fuse-emulator-gtk and fuse-emulator-sdl. I need it for the CURA slicer for my 3D printer
Member

#104615:
Citing from #85721:
For NVIDIA GPUs on Linux, the official recommendation (as also mentioned in the Blender manual) is to use the closed source drivers which do work. We are not currently considering Nouveau drivers to be the officially supported way to run Blender, and so this is not considered a bug we intend to fix in Blender.

Hi, as said in the above comment, official GPU drivers are recommended to run blender.
So I'll close this report since you're using open-source drivers.

Not sure how fuse-emulator is affecting blender UI.

> #104615: Citing from #85721: For NVIDIA GPUs on Linux, the official recommendation (as also mentioned in the Blender manual) is to use the closed source drivers which do work. We are not currently considering Nouveau drivers to be the officially supported way to run Blender, and so this is not considered a bug we intend to fix in Blender. Hi, as said in the above comment, official GPU drivers are recommended to run blender. So I'll close this report since you're using open-source drivers. Not sure how fuse-emulator is affecting blender UI.
Blender Bot added
Status
Archived
and removed
Status
Needs Information from User
labels 2023-03-07 03:57:50 +01:00

Should this be marked as a duplicate of #102994? These appear to refer to the same issue, and #102994 is the earliest iteration of this ticket that I can find.

Should this be marked as a duplicate of #102994? These appear to refer to the same issue, and #102994 is the earliest iteration of this ticket that I can find.

Hi this issue is not solded for me I use an old Blender version
The NVIDIA driver crash my Ubuntu (Kernel Error !!) 2 times !!. the NVdia driver that I found on the NVIDIA website is a 2019 version. Today I'm not found a solution for this issue.

Hi this issue is not solded for me I use an old Blender version The NVIDIA driver crash my Ubuntu (Kernel Error !!) 2 times !!. the NVdia driver that I found on the NVIDIA website is a 2019 version. Today I'm not found a solution for this issue.

Well, I haven't experienced any crashes or kernel errors due to this bug, but I have found some workarounds for my case that might help you. I've recorded them in ticket #111314.

Basically, the transparency issue goes away if I launch Blender from the terminal with the command blender &. I'm sure it would be interesting to learn whether this workaround also works for you! If you try it, would you add your experience to ticket #111314?

Well, I haven't experienced any crashes or kernel errors due to this bug, but I have found some workarounds for my case that might help you. I've recorded them in ticket #111314. Basically, the transparency issue goes away if I launch Blender from the terminal with the command `blender &`. I'm sure it would be interesting to learn whether this workaround also works for you! If you try it, would you add your experience to ticket #111314?

hi Frederick
Tanks for this information, I try it after my holidays

hi Frederick Tanks for this information, I try it after my holidays
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser
Interest
Asset Browser Project Overview
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
3 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#104035
No description provided.