Transparent Background #111314

Open
opened 2023-08-20 07:04:58 +02:00 by Frederick · 4 comments

System Information

Operating system: Graphics card: Report: Owner:
Linux-6.4.9-200.fc38.x86_64-x86_64-with-glibc2.37 64 Bits NV118 Mesa 4.3 (Core Profile) Mesa 23.1.6 #111314 @Bird_Lunch
Manjaro Linux x64 23.1.0 Intel HD Graphics 630 #115571 @swamp-fish

Blender Version
Broken: version: 3.5.1, branch: unknown, commit date: 1970-01-01 00:00, hash: unknown
(It looks like Fedora's package manager breaks commit information.)
Worked: Looking at other tickets, the last working version seems to have been 3.3.

Short description of error
As reported in a couple other issues, Blender's object view shows as transparent when the program is opened.
Blender 3.5 Windowing Issue.png

I also noticed that, in edit mode, the dots indicating vectors and faces are unusually small – almost too small to see. They appear to be only 1 pixel in size. I haven't noticed other tickets mention that symptom.
Blender 3.5 Tiny Vector Nodes.png

I'm using Fedora distribution, GNOME desktop environment, and Wayland windowing system.

Exact steps for others to reproduce the error

  1. Install Blender using the dnf package manager on a Fedora Linux system running Wayland.
  2. Launch Blender from the "Activities" window. As a reminder, this uses the blender.desktop file to launch Blender.

Looking at other tickets, using Fedora does not appear to be a prerequisite to reproducing this bug.

Workarounds
After fiddling with it a bit, I've found some workarounds that may prove illuminating. Here are some changes that cause Blender to behave as expected:

  • Run Blender in full-screen mode. As long as the user stays in full-screen mode, the background is rendered as expected. This does not solve the node issue. You can see this in the second screenshot.
  • Launch Blender from the terminal. For example with blender &. This solves both problems.
  • Launch Blender by double-clicking it in the File explorer. In my case at /usr/bin/blender. This solves both problems.

Basically launching Blender by any method other than the .desktop file seems to solve the issue. I launched a download of Blender 3.6 this way, and did not see the issue, though in that case I couldn't easily launch the .desktop file to replicate the bug.

Here's Blender 3.5 running on the same machine, launched from the terminal using blender &. You can see that, even windowed, the background is opaque and the vector nodes are the right size:
Blender 3.5 from the Terminal.png

Duplicate Issues
I opened this fresh ticket because I haven't seen anyone mention the node issue, or how launching Blender in different ways affects this bug; I wanted to add that information to the discussion.

Managing My Expectations
From the other tickets, I get the impression that this is an issue with drivers, and is out of scope for the Blender team to fix. In lieu of a fix, I would love to see this workaround info added in a place where other users with this problem can find it.

Thank you for your hard work on Blender! I hope this ticket is helpful.

**System Information** | Operating system: | Graphics card: | Report: | Owner: | | -- | -- | -- | -- | | Linux-6.4.9-200.fc38.x86_64-x86_64-with-glibc2.37 64 Bits | NV118 Mesa 4.3 (Core Profile) Mesa 23.1.6 | #111314 | @Bird_Lunch | | Manjaro Linux x64 23.1.0 | Intel HD Graphics 630 | #115571 | @swamp-fish | **Blender Version** Broken: version: 3.5.1, branch: unknown, commit date: 1970-01-01 00:00, hash: `unknown` (It looks like Fedora's package manager breaks commit information.) Worked: Looking at other tickets, the last working version seems to have been 3.3. **Short description of error** As reported in a couple other issues, Blender's object view shows as transparent when the program is opened. ![Blender 3.5 Windowing Issue.png](/attachments/a876de3f-824b-4cd4-a2f0-d1aae7d6ecdf) I also noticed that, in edit mode, the dots indicating vectors and faces are unusually small – almost too small to see. They appear to be only 1 pixel in size. I haven't noticed other tickets mention that symptom. ![Blender 3.5 Tiny Vector Nodes.png](/attachments/ab0e52ec-f824-447c-a58f-e21633d6ca44) I'm using Fedora distribution, GNOME desktop environment, and Wayland windowing system. **Exact steps for others to reproduce the error** 1. Install Blender using the `dnf` package manager on a Fedora Linux system running Wayland. 2. Launch Blender from the "Activities" window. As a reminder, this uses the `blender.desktop` file to launch Blender. Looking at other tickets, using Fedora does not appear to be a prerequisite to reproducing this bug. **Workarounds** After fiddling with it a bit, I've found some workarounds that may prove illuminating. Here are some changes that cause Blender to behave as expected: - Run Blender in full-screen mode. As long as the user stays in full-screen mode, the background is rendered as expected. This does not solve the node issue. You can see this in the second screenshot. - Launch Blender from the terminal. For example with `blender &`. This solves both problems. - Launch Blender by double-clicking it in the File explorer. In my case at `/usr/bin/blender`. This solves both problems. Basically launching Blender by any method other than the .desktop file seems to solve the issue. I launched a download of Blender 3.6 this way, and did not see the issue, though in that case I couldn't easily launch the .desktop file to replicate the bug. Here's Blender 3.5 running on the same machine, launched from the terminal using `blender &`. You can see that, even windowed, the background is opaque and the vector nodes are the right size: ![Blender 3.5 from the Terminal.png](/attachments/cf717d65-603d-4e66-85e6-02934cdaa2ab) **Duplicate Issues** I opened this fresh ticket because I haven't seen anyone mention the node issue, or how launching Blender in different ways affects this bug; I wanted to add that information to the discussion. - The original ticket appears to be #102994. - This issue also appears to be duplicated in #104035, #110327, #103152, #115764, and #103483. **Managing My Expectations** From the other tickets, I get the impression that this is an issue with drivers, and is out of scope for the Blender team to fix. In lieu of a fix, I would love to see this workaround info added in a place where other users with this problem can find it. Thank you for your hard work on Blender! I hope this ticket is helpful.
Frederick added the
Type
Report
Priority
Normal
Status
Needs Triage
labels 2023-08-20 07:04:59 +02:00
Author

In issue #104035, user @Laurent-1 claimed that this issue causes NVIDIA driver crashes and kernel errors in their Ubuntu environment. I haven't experienced these kinds of errors in this ticket, so I wonder how related they are. I encouraged Laurent to try the workarounds documented here and report whether they help.

In issue #104035, user @Laurent-1 claimed that this issue causes NVIDIA driver crashes and kernel errors in their Ubuntu environment. I haven't experienced these kinds of errors in this ticket, so I wonder how related they are. I encouraged Laurent to try the workarounds documented here and report whether they help.
Iliya Katushenock added the
Interest
EEVEE & Viewport
Platform
Linux
labels 2023-08-21 00:14:55 +02:00
Iliya Katushenock changed title from Transparent Background (Known Duplicate with New Detail) to Transparent Background 2023-08-21 00:15:05 +02:00
Member

Hi, thanks for the report and finding some workarounds.
Not sure if we still need a separate task, this is already mentioned as known problem with
Nouveau drivers

Hi, thanks for the report and finding some workarounds. Not sure if we still need a separate task, this is already mentioned as known problem with [Nouveau drivers](https://projects.blender.org/blender/blender/issues/76428#:~:text=%23110327%20Only%203D%20View%2Dport%20region%20is%20transparent%20on%20Wayland%20(NVidia%20%2B%20Nouveau))

Hi Frederick
Many thanks for this solution all is ok for me now !

Hi Frederick Many thanks for this solution all is ok for me now !

Hello I'm arriving a little late, but I can be useful.

I was following @Bird_Lunch steps (by the way, thank you very much), and I noticed that the problem is inside the blender.desktop file.

I'm using a NVidia 2600 card, and it is the default GPU in my Fedora installation.
The problem seems to be due to the parameter

PrefersNonDefaultGPU=true

in the path $HOME/Library/Blender/blender.desktop

My approach was create a new one in $HOME/.local/share/applications/blender.desktop
changing the PrefersNonDefaultGPU parameter to false, so my Blender starts using the integrated GPU instead of discrete.

Something like:

[Desktop Entry]
Name=Blender
Exec=/home/user/Library/Blender/blender
Icon=/home/user/Library/Blender/blender.svg
PrefersNonDefaultGPU=false
Terminal=false
Type=Application

It seems to be a solution to start the application without using the terminal.
You can then configure which card to use in the program's preference settings.

result.jpg

Hello I'm arriving a little late, but I can be useful. I was following @Bird_Lunch steps (by the way, thank you very much), and I noticed that the problem is inside the blender.desktop file. I'm using a NVidia 2600 card, and it is the default GPU in my Fedora installation. The problem seems to be due to the parameter > PrefersNonDefaultGPU=true in the path $HOME/Library/Blender/blender.desktop My approach was create a new one in $HOME/.local/share/applications/blender.desktop changing the PrefersNonDefaultGPU parameter to false, so my Blender starts using the integrated GPU instead of discrete. Something like: ``` [Desktop Entry] Name=Blender Exec=/home/user/Library/Blender/blender Icon=/home/user/Library/Blender/blender.svg PrefersNonDefaultGPU=false Terminal=false Type=Application ``` It seems to be a solution to start the application without using the terminal. You can then configure which card to use in the program's preference settings. ![result.jpg](/attachments/e670e18a-7776-42a2-9c18-4f55c2dd185e)
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser
Interest
Asset Browser Project Overview
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
4 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#111314
No description provided.