Only 3D Viewport region is transparent on Wayland (NVidia + Nouveau) #110327

Closed
opened 2023-07-21 00:52:28 +02:00 by Talha-Qamar · 8 comments

System Information
Operating system: Linux-6.4.4-arch1-1-x86_64-with-glibc2.37 64 Bits, WAYLAND UI
Graphics card: NVE6 Mesa 4.3 (Core Profile) Mesa 23.1.3
Non Autofilled GPU: Nvidia Geforce GTX 660

Blender Version
Broken: version: 3.6.0, branch: makepkg (modified), commit date: 2023-06-27 08:08, hash: c7fc78b81ecb
Worked: (newest version of Blender that worked as expected)

Short description of error
I can see my wallpaper through the viewport as seen here;
20230720_23h47m30s_grim.png

I tried it with i3 instead of sway it worked fine, this is a wayland specific issue
Running blender from the console gives me 6 of this error

EGL Error (0x3009): EGL_BAD_MATCH: Arguments are inconsistent (for example, a valid context requires buffers not supplied by a valid surface).

and one of this error

Failed to open dir (No such file or directory): /run/user/1000/gvfs/

I reproduced this bug on the version of blender on the website and also the daily build. Please let me know if there's any other info I can provide to help.

Exact steps for others to reproduce the error

  • downloaded latest blender from the website
  • I opened it on wayland
  • there's the bug

[Based on the default startup or an attached .blend file (as simple as possible)]

**System Information** Operating system: Linux-6.4.4-arch1-1-x86_64-with-glibc2.37 64 Bits, WAYLAND UI Graphics card: NVE6 Mesa 4.3 (Core Profile) Mesa 23.1.3 Non Autofilled GPU: Nvidia Geforce GTX 660 **Blender Version** Broken: version: 3.6.0, branch: makepkg (modified), commit date: 2023-06-27 08:08, hash: `c7fc78b81ecb` Worked: (newest version of Blender that worked as expected) **Short description of error** I can see my wallpaper through the viewport as seen here; ![20230720_23h47m30s_grim.png](/attachments/336f6260-e0fc-406b-b599-08d33647d776) I tried it with i3 instead of sway it worked fine, this is a wayland specific issue Running blender from the console gives me 6 of this error ``` EGL Error (0x3009): EGL_BAD_MATCH: Arguments are inconsistent (for example, a valid context requires buffers not supplied by a valid surface). ``` and one of this error ``` Failed to open dir (No such file or directory): /run/user/1000/gvfs/ ``` I reproduced this bug on the version of blender on the website and also the daily build. Please let me know if there's any other info I can provide to help. **Exact steps for others to reproduce the error** - downloaded latest blender from the website - I opened it on wayland - there's the bug [Based on the default startup or an attached .blend file (as simple as possible)]
Talha-Qamar added the
Type
Report
Status
Needs Triage
Priority
Normal
labels 2023-07-21 00:52:28 +02:00
Author

After a bit more digging on my part I found this forum post about wayland support. Has wayland support not been merged in?

After a bit more digging on my part I found [this forum post](https://devtalk.blender.org/t/wayland-and-egl-support/11171/10) about wayland support. Has wayland support not been merged in?
Member

The wayland support is already in, but somewhat buggy.

This is different from #102999, you only have a viewport that's blank, suggesting it not being drawn in any way. Could be driver issue, NVE6 Mesa 4.3 (Core Profile) Mesa 23.1.3 suggests you are probably not using proprietary driver from NVidia? Usually using their driver can result in less trouble overall.

The wayland support is already in, but somewhat buggy. This is different from #102999, you only have a viewport that's blank, suggesting it not being drawn in any way. Could be driver issue, `NVE6 Mesa 4.3 (Core Profile) Mesa 23.1.3` suggests you are probably not using proprietary driver from NVidia? Usually using their driver can result in less trouble overall.
YimingWu added the
Interest
Wayland
label 2023-07-21 04:17:40 +02:00
YimingWu changed title from Viewport is transparent on wayland to Only 3D Viewport region is transparent on wayland 2023-07-21 04:18:07 +02:00
Member

Could you try with official Nvidia drivers as Yiming said? I guess Nouveau drivers are not supported.
Similar issue has been reported before with Nouveau drivers drivers, see: #104035 / #102994

Could you try with official Nvidia drivers as Yiming said? I guess Nouveau drivers are not supported. Similar issue has been reported before with Nouveau drivers drivers, see: #104035 / #102994
Pratik Borhade added
Status
Needs Information from User
and removed
Status
Needs Triage
labels 2023-07-21 04:49:55 +02:00
Author

After trying out the proprietary driver, the issue does not occur! However; pretty much everything else surrounding blender breaks. Most wayland compositors straight up refuse to boot off of nvidia instead of nouveau. I got Plasma to work with nvidia and tested it that way; but everything was so slow that it was basically unusable. (There were 3 seconds between me moving my mouse and it updating on screen).

So while Blender might work better with proprietary drivers, wayland seems to very much not; or so says my experience.

After trying out the proprietary driver, the issue does not occur! However; pretty much everything else surrounding blender breaks. Most wayland compositors straight up refuse to boot off of nvidia instead of nouveau. I got Plasma to work with nvidia and tested it that way; but everything was so slow that it was basically unusable. (There were 3 seconds between me moving my mouse and it updating on screen). So while Blender might work better with proprietary drivers, wayland seems to very much not; or so says my experience.
Author

I notice that the tag still reads "requires info from user", how else can I help?

I notice that the tag still reads "requires info from user", how else can I help?
Campbell Barton changed title from Only 3D Viewport region is transparent on wayland to Only 3D Viewport region is transparent on Wayland (NVidia + Nouveau) 2023-07-24 03:40:08 +02:00

Listed this report from #76428 however nouveau drivers are known to have many limitations compared with NVidia's drivers.

Closing this report as NVidia's drivers having poor (even broken) Wayland support is also out of our control.

This is a documented limitation:
https://docs.blender.org/manual/en/latest/getting_started/installing/linux_windowing_environment.html#wayland

Listed this report from #76428 however nouveau drivers are known to have many limitations compared with NVidia's drivers. Closing this report as NVidia's drivers having poor (even broken) Wayland support is also out of our control. This is a documented limitation: https://docs.blender.org/manual/en/latest/getting_started/installing/linux_windowing_environment.html#wayland
Blender Bot added
Status
Archived
and removed
Status
Needs Information from User
labels 2023-07-24 03:44:35 +02:00

Should this be marked as a duplicate of #102994? These appear to refer to the same issue, and #102994 is the earliest iteration of this ticket that I can find.

Should this be marked as a duplicate of #102994? These appear to refer to the same issue, and #102994 is the earliest iteration of this ticket that I can find.
Author

Seems to be the same yeah.

Seems to be the same yeah.
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser
Interest
Asset Browser Project Overview
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
5 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#110327
No description provided.