Replace legacy instancing panel #105321

Open
opened 2023-02-28 23:36:12 +01:00 by Hans Goudey · 7 comments
Member

image
image

These instancing features have been replaced by geometry nodes. They can be replaced by node groups added in modifiers by versioning code.

![image](/attachments/b184253e-dbc2-408a-95e1-e0af4738c536) ![image](/attachments/dfa42e76-8d94-48b7-848f-0ea98a25e5c3) These instancing features have been replaced by geometry nodes. They can be replaced by node groups added in modifiers by versioning code.
Hans Goudey added this to the 4.0 milestone 2023-02-28 23:36:12 +01:00
Hans Goudey added the
Type
To Do
Interest
Geometry Nodes
Module
Nodes & Physics
labels 2023-02-28 23:36:12 +01:00
Hans Goudey added this to the Nodes & Physics project 2023-02-28 23:36:13 +01:00
Hans Goudey added the
Interest
Modeling
label 2023-02-28 23:36:20 +01:00
Iliya Katushenock self-assigned this 2023-03-01 09:44:25 +01:00

After a little research, I see that the task can be completed in several stages:

  1. Versioning creating a modifier and turning off the instance function. There are no functional changes.
  2. Delete the setting panel and her RNA API.
  3. Start removing the entire code of the dupliobject using this. Here I will need to study what it is.
  4. Finally, i can think about removing the settings from the structure of the object.
After a little research, I see that the task can be completed in several stages: 1. Versioning creating a modifier and turning off the instance function. There are no functional changes. 2. Delete the setting panel and her RNA API. 3. Start removing the entire code of the dupliobject using this. Here I will need to study what it is. 4. Finally, i can think about removing the settings from the structure of the object.

Here are a couple of examples of the interface in the modifier
image
image

Here are a couple of examples of the interface in the modifier ![image](/attachments/cb8c64b6-d5ff-4667-9afe-8fcef4290444) ![image](/attachments/55fbd846-286f-4814-bed6-c8df05ab06bf)

And also the topic of discussion on this forum https://devtalk.blender.org/t/remove-legacy-instancing/28028

And also the topic of discussion on this forum https://devtalk.blender.org/t/remove-legacy-instancing/28028

Will there be a way to convert the GeoNodes instances to separate objects sharing data with each other? Because having to realize instances in order to make simple transform-type edits to individual objects means creating a lot of unnecessary geometry. As it is right now, trying to apply a node modifier that includes instances just deletes all the instances.

Will there be a way to convert the GeoNodes instances to separate objects sharing data with each other? Because having to realize instances in order to make simple transform-type edits to individual objects means creating a lot of unnecessary geometry. As it is right now, trying to apply a node modifier that includes instances just deletes all the instances.

@hmturnbull bpy.ops.object.duplicates_make_real()'s command should alredy solve this problem?

@hmturnbull `bpy.ops.object.duplicates_make_real()`'s command should alredy solve this problem?

Will this also include removing collection instancing via empties? I know the asset browser uses this too.
image

Will this also include removing collection instancing via empties? I know the asset browser uses this too. ![image](/attachments/d2edad33-943b-4c77-9f5c-3a55b5c228ce)
Author
Member

No, at least that isn't included in this task, it can be handled internally much more easily and wouldn't have the same benefits. Though I do think the UI for collection instances could be improved!

No, at least that isn't included in this task, it can be handled internally much more easily and wouldn't have the same benefits. Though I do think the UI for collection instances could be improved!
Hans Goudey changed title from Remove legacy instancing panel for 4.0 to Replace legacy instancing panel for 4.0 2023-07-25 16:05:30 +02:00
Hans Goudey changed title from Replace legacy instancing panel for 4.0 to Replace legacy instancing panel 2023-10-08 14:15:37 +02:00
Iliya Katushenock removed this from the 4.0 milestone 2023-10-11 07:46:57 +02:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser Project (Legacy)
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No Assignees
4 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#105321
No description provided.