Instancing. Visibility of instances should not be taken from the source. #105702

Closed
opened 2023-03-12 21:06:29 +01:00 by Pete Bateman · 9 comments

UBuntu 20.04, RTX3090

Blender - 3.4

Broken: All versions

The visibility status of instances is taken from the visibility status of the source geometry. The only way to remove the source from the viewport is to hide it. Which is undone the moment you hit alt-h for any reason.

Exact steps for others to reproduce the error
Add a grid. Parent the default cube to the grid. Enable instancing on the grid. The source/child object remains visible. Outliner-> disable in viewport. Watch your instances disappear along with the source.

UBuntu 20.04, RTX3090 Blender - 3.4 Broken: All versions The visibility status of instances is taken from the visibility status of the source geometry. The only way to remove the source from the viewport is to hide it. Which is undone the moment you hit alt-h for any reason. Exact steps for others to reproduce the error Add a grid. Parent the default cube to the grid. Enable instancing on the grid. The source/child object remains visible. Outliner-> disable in viewport. Watch your instances disappear along with the source.
Pete Bateman added the
Priority
Normal
Type
Report
Status
Needs Triage
labels 2023-03-12 21:06:30 +01:00

This is expected behavior, isn't it?

This is expected behavior, isn't it?
Author

In the sense that this is how it's always been done, yes. In the sense that it's not at all useful, annoying and illogical, no.

In the sense that this is how it's always been done, yes. In the sense that it's not at all useful, annoying and illogical, no.
Author

It's not even internally consistent behavior -

Currently the source and instances settings produce different results -

Source visibility follows this logic -
Screenshot from 2023-03-13 12-37-48.png

Instance visibility follows this logic -
Screenshot from 2023-03-13 12-38-14.png

Whereas both could just follow the same logic leaving the whole thing so much more easy to control.
Screenshot from 2023-03-13 12-38-27.png

It's not even internally consistent behavior - Currently the source and instances settings produce different results - Source visibility follows this logic - ![![Screenshot from 2023-03-13 12-37-48.png](/attachments/a6ffb231-6db8-4ea5-9367-325615ca382a)](https://) Instance visibility follows this logic - ![![Screenshot from 2023-03-13 12-38-14.png](/attachments/49dcf975-de03-4938-bc12-34248f64c0b4)](https://) Whereas both could just follow the same logic leaving the whole thing so much more easy to control. ![![Screenshot from 2023-03-13 12-38-27.png](/attachments/c1650665-d590-4687-9878-8040a7d6b671)](https://)

You can do this if you think it's important. But if it's not a regression, then it's not a bug. And also, given #105321 , is this not a priority?

You can do this if you think it's important. But if it's not a regression, then it's not a bug. And also, given https://projects.blender.org/blender/blender/issues/105321 , is this not a priority?
Blender Bot added
Status
Archived
and removed
Status
Needs Triage
labels 2023-03-13 14:15:11 +01:00
Author

So we're proposing to completely disable the only method that allows us to instance lights?

So we're proposing to completely disable the only method that allows us to instance lights?

You can still instantiate objects and collections. Just don't treat it as geometry.

You can still instantiate objects and collections. Just don't treat it as geometry.
Author

I'm not clear on how this is helping. I can currently create one light, instance it on a grid, then extrude or delete vertices as I like.

The only problem being that I have no effective control over weather the source appears in the viewport or the render, or not. Hence this post.

Remove this and I have to manually duplicate and place each one individually. You can't array lights, you can't use them in geometry nodes that I'm aware of.

This all seems like a regressive step to me. Unless there is some other method I just haven't discovered yet?

I'm not clear on how this is helping. I can currently create one light, instance it on a grid, then extrude or delete vertices as I like. The only problem being that I have no effective control over weather the source appears in the viewport or the render, or not. Hence this post. Remove this and I have to manually duplicate and place each one individually. You can't array lights, you can't use them in geometry nodes that I'm aware of. This all seems like a regressive step to me. Unless there is some other method I just haven't discovered yet?
Author

Nice. Thanks for this.

Nice. Thanks for this.
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Asset Browser Project
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
2 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#105702
No description provided.