X-ray anomaly in edit mode. #107369

Closed
opened 2023-04-26 13:28:09 +02:00 by Ian Jones · 20 comments

System Information
Operating system: macOS-13.3-arm64-arm-64bit 64 Bits
Graphics card: Apple M1 Max Apple 4.1 Metal - 83.1

Blender Version
Broken: version: 3.6.0 Alpha, branch: main, commit date: 2023-04-24 21:01, hash: 3507431c3064
Worked: (newest version of Blender that worked as expected)

Short description of error
When in edit mode there is a strange visual anomaly when up close to a mesh. This also effects the ability to select elements of the mesh.

Exact steps for others to reproduce the error
Enter edit mode and move close to a mesh. Moving in and out varies the effect and trying to select mesh elements in the effected area isn't possible.

**System Information** Operating system: macOS-13.3-arm64-arm-64bit 64 Bits Graphics card: Apple M1 Max Apple 4.1 Metal - 83.1 **Blender Version** Broken: version: 3.6.0 Alpha, branch: main, commit date: 2023-04-24 21:01, hash: `3507431c3064` Worked: (newest version of Blender that worked as expected) **Short description of error** When in edit mode there is a strange visual anomaly when up close to a mesh. This also effects the ability to select elements of the mesh. **Exact steps for others to reproduce the error** Enter edit mode and move close to a mesh. Moving in and out varies the effect and trying to select mesh elements in the effected area isn't possible.
Ian Jones added the
Priority
Normal
Type
Report
Status
Needs Triage
labels 2023-04-26 13:28:09 +02:00
Member

Hi, thanks for the report.

Enter edit mode and move close to a mesh

Which mesh-object you're referring to? Could you expand more on reproducing steps (maybe share screen-recording to show us the issue you're observing)?

Hi, thanks for the report. > Enter edit mode and move close to a mesh Which mesh-object you're referring to? Could you expand more on reproducing steps (maybe share screen-recording to show us the issue you're observing)?
Pratik Borhade added
Status
Needs Information from User
and removed
Status
Needs Triage
labels 2023-04-26 13:57:01 +02:00
Author

I have shared a screen recording.

I have shared a screen recording.
Author

Here it is again if it didn't upload.

Here it is again if it didn't upload.
Member

Still not uploaded :/

Still not uploaded :/
Author

Try this.

Try this.
Author

It doesn't appear to be uploading.

It doesn't appear to be uploading.
Author

Finally uploaded.

Finally uploaded.
Member

Thanks. uploaded file and the one shown in the video looks bit different.
This might be happening due to clipping and precision. Tweak clip-start and end values and see if that makes any difference.

Thanks. uploaded file and the one shown in the video looks bit different. This might be happening due to clipping and precision. Tweak clip-start and end values and see if that makes any difference.
Author

That make no difference.

That make no difference.
Author

New screen capture on different file.

New screen capture on different file.
Pratik Borhade added
Status
Needs Triage
and removed
Status
Needs Information from User
labels 2023-05-02 13:00:34 +02:00

I believe this may have possibly been fixed by this PR: #108048

Which resolved a separate depth bias issue, but could also be the same root cause. Could you please let me know if it is still occurring in the latest 3.6 alpha? (https://builder.blender.org/download/daily/)

I believe this may have possibly been fixed by this PR: https://projects.blender.org/blender/blender/pulls/108048 Which resolved a separate depth bias issue, but could also be the same root cause. Could you please let me know if it is still occurring in the latest 3.6 alpha? (https://builder.blender.org/download/daily/)
Author

Initially I thought this had been fixed in 4.0 Alpha but this occurred.

Initially I thought this had been fixed in 4.0 Alpha but this occurred.

Is FileDefaultsLoad Factory Settings change something?

Is `File` → `Defaults` → `Load Factory Settings` change something?
Author

Factory settings for both 3.6 and 4.0 latest as of 25 June. No change. See screen recordings.

Factory settings for both 3.6 and 4.0 latest as of 25 June. No change. See screen recordings.

@Macwelshman Have you seen both video yourself?
image

@Macwelshman Have you seen both video yourself? ![image](/attachments/e8312cc4-146b-43c1-8f42-bd5eb2effd4f)
398 KiB
Author

I created them. Why?

I created them. Why?
Author

I see. I'm redo them.

I see. I'm redo them.
Member

This looks exactly like #109040 and other related reports.
On other platforms, this is resolved in 3.6.1, but on MAC this still seems to be a problem (even in 3.6.1).

However, there is a particular report for this (which already has the relevant developers on it), see #110048, so will close this as a duplicate. Please subscribe in #110048 if you want further updates.

If this is a misunderstanding and you feel this is not the same as #110048 please also feel free to comment again (we can always reopen in such case).

This looks exactly like #109040 and other related reports. On other platforms, this is resolved in 3.6.1, but on MAC this still seems to be a problem (even in 3.6.1). However, there is a particular report for this (which already has the relevant developers on it), see #110048, so will close this as a duplicate. Please subscribe in #110048 if you want further updates. If this is a misunderstanding and you feel this is not the same as #110048 please also feel free to comment again (we can always reopen in such case).
Blender Bot added
Status
Archived
and removed
Status
Needs Triage
labels 2023-07-19 15:03:12 +02:00

No. look at my last ticket exactly overlay focus only for METAL.
Open GL is perfect. METAL lot BUG!
#110048

No. look at my last ticket exactly overlay focus only for METAL. Open GL is perfect. METAL lot BUG! https://projects.blender.org/blender/blender/issues/110048
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser
Interest
Asset Browser Project Overview
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
6 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#107369
No description provided.