Overlay: Edit Mesh wireframe incorrect bias #109040

Closed
opened 2023-06-16 04:22:40 +02:00 by choihojin · 19 comments
First-time contributor

System Information
Operating system: Windows-10-10.0.19045-SP0 64 Bits
Graphics card: NVIDIA GeForce RTX 3080 Ti/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 531.61

Blender Version
Broken: version: 3.6.0 Beta, branch: blender-v3.6-release, commit date: 2023-06-14 20:36, hash: 977081d72be6
Worked: 3.5

Caused by dcad51dfc3

Short description of error

When objects overlap, an additional section of wireframe is displayed in edit mode. This can be seen when zooming in.

Exact steps for others to reproduce the error

  • Zoom in very closely
  • Enlarging overlapping objects in edit mode makes them look like images.
**System Information** Operating system: Windows-10-10.0.19045-SP0 64 Bits Graphics card: NVIDIA GeForce RTX 3080 Ti/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 531.61 **Blender Version** Broken: version: 3.6.0 Beta, branch: blender-v3.6-release, commit date: 2023-06-14 20:36, hash: `977081d72be6` Worked: 3.5 Caused by dcad51dfc3c5ead718bfe744669effdc304f79fb **Short description of error** When objects overlap, an additional section of wireframe is displayed in edit mode. This can be seen when zooming in. **Exact steps for others to reproduce the error** - Zoom in very closely - Enlarging overlapping objects in edit mode makes them look like images.
choihojin added the
Type
Report
Status
Needs Triage
Priority
Normal
labels 2023-06-16 04:22:40 +02:00
Member

Hi @hominy , this is the natural side-effect of z-offsetting on wireframe layer when having a really close zoom (otherwise the wireframe will be drawn directly at the depth of the surface, which will lead to flicker) . try work on the scene in a bigger overall scale to mitigate the issue.

Will close this for now since it's more of a known issue.

Hi @hominy , this is the natural side-effect of z-offsetting on wireframe layer when having a really close zoom (otherwise the wireframe will be drawn directly at the depth of the surface, which will lead to flicker) . try work on the scene in a bigger overall scale to mitigate the issue. Will close this for now since it's more of a known issue.
Blender Bot added
Status
Archived
and removed
Status
Needs Triage
labels 2023-06-16 05:33:58 +02:00
YimingWu added the
Interest
EEVEE & Viewport
label 2023-06-16 05:34:08 +02:00
Author
First-time contributor

It doesn't happen in 3.5

It doesn't happen in 3.5
Member

@fclem any idea what this is?

@fclem any idea what this is?
YimingWu reopened this issue 2023-06-25 15:51:11 +02:00
Blender Bot added
Status
Needs Triage
and removed
Status
Archived
labels 2023-06-25 15:51:13 +02:00

That might have to do with the new retopology Z-bias that fails when one of the vertex is behind the nearplane or the camera origin.

CC @bonj

That might have to do with the new retopology Z-bias that fails when one of the vertex is behind the nearplane or the camera origin. CC @bonj
Contributor

It shouldn't affect anything when retopology overlay isn't enabled.
And when it is enabled, there's math that prevents vertices from being offset too far.
In conclusion, I don't know what's going on.

It shouldn't affect anything when retopology overlay isn't enabled. And when it is enabled, there's math that prevents vertices from being offset too far. In conclusion, I don't know what's going on.
Clément Foucault changed title from Viewport Bug to Overlay: Edit Mesh wireframe incorrect bias 2023-06-26 16:28:40 +02:00
Member

Can confirm. I'll raise the priority since this is a regression.

Issue does not happen prior to retopology overlay commit

Can confirm. I'll raise the priority since this is a regression. Issue does not happen prior to `retopology overlay` commit
Iliya Katueshenock added this to the 3.6 LTS milestone 2023-06-30 19:04:03 +02:00

@bonj Can you reproduce this bug?

@bonj Can you reproduce this bug?
Contributor

@mod_moder Yep, it happened to me earlier today. Messing with view clipping distances doesn't seem to affect it.
I suppose the math in the overlay shader needs adjusting.
Should be easy enough because we know what commit caused it.
I probably won't have time today but should be able to make time tomorrow.

@mod_moder Yep, it happened to me earlier today. Messing with view clipping distances doesn't seem to affect it. I suppose the math in the overlay shader needs adjusting. Should be easy enough because we know what commit caused it. I probably won't have time today but should be able to make time tomorrow.
First-time contributor

I'm having this problem a lot too since 3.6 released. Its been annoying me on multiple projects. Mine looks a bit different so here is a video of it.

I'm having this problem a lot too since 3.6 released. Its been annoying me on multiple projects. Mine looks a bit different so here is a video of it.
First-time contributor

Thanks @PratikPB2123 very muchhhhhh

Thanks @PratikPB2123 very muchhhhhh
First-time contributor

Version 3.4.1 is fine
3.5 or 3.6 see picture
EDIT WIDTH size is new feature cause overlap.
Not only edge. Both face and edge .
image
Face still overlap too.
image

There 3.4.1 have no overlap without edge size number.
image

Version 3.4.1 is fine 3.5 or 3.6 see picture EDIT WIDTH size is new feature cause overlap. Not only edge. Both face and edge . ![image](/attachments/1cb7d90f-4f9b-451c-b545-f05ac2b8ed6b) Face still overlap too. ![image](/attachments/b4d81dbd-ebcc-48ca-aee3-e62924a64b4c) There 3.4.1 have no overlap without edge size number. ![image](/attachments/6c411f59-498f-4585-bce9-4af6c838a453)
Blender Bot added
Status
Resolved
and removed
Status
Confirmed
labels 2023-07-11 11:44:28 +02:00
First-time contributor

@fclem There resolve cause Push the Command + R doesn't show edge line.

@fclem There resolve cause Push the Command + R doesn't show edge line.
First-time contributor

Broken: version: 4.0.0 Alpha, branch: main, commit date: 2023-07-08 23:26, hash: b183e3ae89a6
Worked: (newest version of Blender that worked as expected)

Overlap edge and Command + R appear edge there.
https://imgur.com/WYKqWYA

and

Broken: version: 4.0.0 Alpha, branch: main, commit date: 2023-07-11 20:50, hash: c728fa0663b6
Worked: (newest version of Blender that worked as expected)

Resolve overlap edge cause Command + R doesn't show edge that bug!
https://imgur.com/Q6VkdEq

Broken: version: 4.0.0 Alpha, branch: main, commit date: 2023-07-08 23:26, hash: `b183e3ae89a6` Worked: (newest version of Blender that worked as expected) Overlap edge and Command + R appear edge there. https://imgur.com/WYKqWYA and Broken: version: 4.0.0 Alpha, branch: main, commit date: 2023-07-11 20:50, hash: `c728fa0663b6` Worked: (newest version of Blender that worked as expected) Resolve overlap edge cause Command + R doesn't show edge that bug! https://imgur.com/Q6VkdEq
First-time contributor

There still not resolve still. https://imgur.com/mSCFuAD there still overlay.

There still not resolve still. https://imgur.com/mSCFuAD there still overlay.
First-time contributor

For me the issue is also still present, no change in most recent 3.6.1 or 4.0.0 versions.

For me the issue is also still present, no change in most recent 3.6.1 or 4.0.0 versions.
Member

guess will reopen this.

guess will reopen this.
YimingWu reopened this issue 2023-07-14 04:55:03 +02:00
Blender Bot added
Status
Needs Triage
and removed
Status
Resolved
labels 2023-07-14 04:55:40 +02:00
Member

@ChengduLittleA , we already have a new report about this: #110048
I'd prefer to close this :)

@ChengduLittleA , we already have a new report about this: #110048 I'd prefer to close this :)
First-time contributor

Just adding to create some more context:

A related issue seems to be that in 3.6.0 there is a blue overlay on the mesh when in edit mode. And it's with the default prefs. It looks like it's from the retopology overlay but this is disabled. Yet the blue overlay is still there.
The overlay conflicts with the display of the mesh, mostly at intersections, where there is a visible offset. This 'ghosting' effect makes it hard to work precisely because it hides where the real intersection of the mesh is. It produces sort of a x-ray effect close to the intersection, where hidden lines are visible. This seems to be a clipping/precision issue.

The issue appears in 3.6.0
It seem to be fixed in 3.6.1 release candidate and 4.0.0 as of today.
Also, the blue overlay is gone.

Just adding to create some more context: A related issue seems to be that in 3.6.0 there is a blue overlay on the mesh when in edit mode. And it's with the default prefs. It looks like it's from the retopology overlay but this is disabled. Yet the blue overlay is still there. The overlay conflicts with the display of the mesh, mostly at intersections, where there is a visible offset. This 'ghosting' effect makes it hard to work precisely because it hides where the real intersection of the mesh is. It produces sort of a x-ray effect close to the intersection, where hidden lines are visible. This seems to be a clipping/precision issue. The issue appears in 3.6.0 It seem to be fixed in 3.6.1 release candidate and 4.0.0 as of today. Also, the blue overlay is gone.
Contributor

The blue faces in edit mode are from the retopology overlay, which is always enabled on Apple computers (issue #109662 / #109779, fixed by pull #109658)
This bug is separate from other offset issues people have been reporting.
If your faces are blue even though the retopology overlay is disabled, please update Blender.

The blue faces in edit mode are from the retopology overlay, which is always enabled on Apple computers (issue #109662 / #109779, fixed by pull #109658) This bug is separate from other offset issues people have been reporting. If your faces are blue even though the retopology overlay is disabled, please update Blender.
Blender Bot added
Status
Archived
and removed
Status
Needs Triage
labels 2023-07-17 07:22:43 +02:00
Pratik Borhade added
Status
Resolved
and removed
Status
Archived
labels 2023-07-17 07:22:57 +02:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser
Interest
Asset Browser Project Overview
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
10 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#109040
No description provided.