Viewport Z-Bias & retopology overlay related issues #109545

Open
opened 2023-06-30 06:42:44 +02:00 by YimingWu · 5 comments
Member

Since this is being reported frequently and retopology overly has caused some weird issue with mask display as well previously, it's best we keep track of them in a central place so we could check if any particular fix is working for all situations:


Problem still presents:

  • Retopology overlay affecting other parts of the drawing/picking operation: #109115 #107768 #109277 #107411
  • (Potentially related) Selecting when X-Ray turned on is not visually effective and then switching to face mode crashes: #110136

Fixed:


Probable cause:

As suggested in #107768 (comment) , I believe the problem here is that

  1. DRW_object_is_in_edit_mode does not exclusively check if object is in edit mode, but it combines other logics that affects drawing and stuff.
  2. XRAY_ENABLED marco is not always accompanied with RETOPOLOGY_ENABLED, this leads to inconsistencies in the user interaction and the display.
Since this is being reported frequently and retopology overly has caused some weird issue with mask display as well previously, it's best we keep track of them in a central place so we could check if any particular fix is working for all situations: ------ Problem still presents: - Retopology overlay affecting other parts of the drawing/picking operation: #109115 #107768 ~~#109277~~ ~~#107411~~ - (Potentially related) Selecting when X-Ray turned on is not visually effective and then switching to face mode crashes: #110136 ------ Fixed: - ~~Wireframe visible in close distances: #110048 #109040 #109514 #109499 #109685~~ - ~~Retopology overlay 0 z offset problem: #109662~~ ------- Probable cause: As suggested in https://projects.blender.org/blender/blender/issues/107768#issuecomment-937545 , I believe the problem here is that 1. `DRW_object_is_in_edit_mode` does not exclusively check if object is in edit mode, but it combines other logics that affects drawing and stuff. 2. `XRAY_ENABLED` marco is not always accompanied with `RETOPOLOGY_ENABLED`, this leads to inconsistencies in the user interaction and the display.
YimingWu added the
Type
To Do
Priority
Normal
Module
EEVEE & Viewport
Status
Confirmed
labels 2023-06-30 06:42:45 +02:00

Since I am absolutely new to this webpage, and I don't know how this works, this might be a odd question. But is the issue fixed now? I tried to download an installer again, but the issue persist. I don't consider it to be something major, but it is of slight annoyance. Anyway, thank you all for your amazing work on this software, you are awesome.

Since I am absolutely new to this webpage, and I don't know how this works, this might be a odd question. But is the issue fixed now? I tried to download an installer again, but the issue persist. I don't consider it to be something major, but it is of slight annoyance. Anyway, thank you all for your amazing work on this software, you are awesome.
Author
Member

@Milos-Ujmiak No these issues are not completely resolved as of now, this page is for the convenience of referencing for developers.

@Milos-Ujmiak No these issues are not completely resolved as of now, this page is for the convenience of referencing for developers.

Related task has been closed. Can this still can be reproduced?

Related task has been closed. Can this still can be reproduced?
Author
Member

Will re-check and remove resolved issue listed here.

Will re-check and remove resolved issue listed here.
Author
Member

Updated the list for still unresolved bugs.

Updated the list for still unresolved bugs.
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser
Interest
Asset Browser Project Overview
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
3 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#109545
No description provided.