Regression: Cycles render crash using F12 render after running script that uses bpy.ops.render #109718

Closed
opened 2023-07-04 22:53:17 +02:00 by John · 9 comments

System Information
Operating system: Windows 10
Graphics card: NVIDIA GeForce GTX 1080

Blender Version
Broken: 3.5.0
Broken: 3.4.0
Worked: 3.3 LTS

Caused by 21acfbe348

I have an operator in a script which automates the process of rendering sprites by rendering an image on a frame of animation in blender multiple times, once for each desired camera angle. In some (but not all) projects, after this script is run and performs its task successfully, from that point onward, if at any point you execute a regular render operation via F12, Blender will crash when the first image finishes compositing. As of yet I've been unable to identify a marker for a project which does, and one which does not have this crash.

A few extra notes:

  • This crash is specific to the Cycles renderer. Eevee renderer does not produce the crash.
  • Repeating the operation does not produce the crash.
  • Using Rendered view mode in the 3D viewport does not produce the crash.

Exact steps for others to reproduce the error

  • Open the attached .blend file
  • Run the attached script
  • Navigate to the Output properties window and run the GRP Tools > Output GRPs operation
  • After the operation is completed, render the scene using F12
  • You should expect a crash

109718_ASAN.txt

**System Information** Operating system: Windows 10 Graphics card: NVIDIA GeForce GTX 1080 **Blender Version** Broken: 3.5.0 Broken: 3.4.0 Worked: 3.3 LTS Caused by 21acfbe348a433cb6ef5c422b1da232355fa51ab I have an operator in a script which automates the process of rendering sprites by rendering an image on a frame of animation in blender multiple times, once for each desired camera angle. In some (but not all) projects, after this script is run and performs its task successfully, from that point onward, if at any point you execute a regular render operation via F12, Blender will crash when the first image finishes compositing. As of yet I've been unable to identify a marker for a project which does, and one which does not have this crash. A few extra notes: - This crash is specific to the Cycles renderer. Eevee renderer does not produce the crash. - Repeating the operation does not produce the crash. - Using Rendered view mode in the 3D viewport does not produce the crash. **Exact steps for others to reproduce the error** - Open the attached .blend file - Run the attached script - Navigate to the Output properties window and run the GRP Tools > Output GRPs operation - After the operation is completed, render the scene using F12 - You should expect a crash [109718_ASAN.txt](/attachments/980706a4-586a-48bf-8817-3f4962df89f5)
John added the
Status
Needs Triage
Type
Report
Priority
Normal
labels 2023-07-04 22:53:18 +02:00
John changed title from Cycles render crash using F12 render after running script using bpy.ops.render to Cycles render crash using F12 render after running script that uses bpy.ops.render 2023-07-04 23:15:38 +02:00

I've got error when running script.

Python: Traceback (most recent call last):
  File "C:\Users\John\Desktop\work\bugs\109718.blend\Text", line 379, in <module>
  File "C:\Users\John\Desktop\work\bugs\109718.blend\Text", line 363, in register
TypeError: validating class: AddonPreferences.bl_idname doesn't support None from string types

Can you provide .crash.txt file? Can you perhaps simplify the script to be a simple procedure?

I've got error when running script. ``` Python: Traceback (most recent call last): File "C:\Users\John\Desktop\work\bugs\109718.blend\Text", line 379, in <module> File "C:\Users\John\Desktop\work\bugs\109718.blend\Text", line 363, in register TypeError: validating class: AddonPreferences.bl_idname doesn't support None from string types ``` Can you provide .crash.txt file? Can you perhaps simplify the script to be a simple procedure?
Richard Antalik added
Status
Needs Information from User
and removed
Status
Needs Triage
labels 2023-07-05 04:17:53 +02:00
Author

Sorry, I don't know exactly what would cause that error for you where it did not for me. Merely removing everything under the class definition PREFERENCE_PT_grpt should resolve it though, which is fine since it isn't pertinent to the test. Hopefully this is sufficient.

Sorry, I don't know exactly what would cause that error for you where it did not for me. Merely removing everything under the class definition PREFERENCE_PT_grpt should resolve it though, which is fine since it isn't pertinent to the test. Hopefully this is sufficient.
Author

Here is a relevant crash log

Here is a relevant crash log

Sorry, I don't know exactly what would cause that error for you where it did not for me. Merely removing everything under the class definition PREFERENCE_PT_grpt should resolve it though, which is fine since it isn't pertinent to the test. Hopefully this is sufficient.

Could be, that I am running Blender 4.0. That said, I wasn't able to reproduce this issue with 3.5 or 4.0. Tried CPU or GPU rendering.
From crash file I can imagine this may be due to outdated GPU driver, but other than that I have no idea. So please update GPU driver if possible and recheck.

> Sorry, I don't know exactly what would cause that error for you where it did not for me. Merely removing everything under the class definition PREFERENCE_PT_grpt should resolve it though, which is fine since it isn't pertinent to the test. Hopefully this is sufficient. Could be, that I am running Blender 4.0. That said, I wasn't able to reproduce this issue with 3.5 or 4.0. Tried CPU or GPU rendering. From crash file I can imagine this may be due to outdated GPU driver, but other than that I have no idea. So please update GPU driver if possible and recheck.
Author

I feel like I updated my drivers relatively recently, but I'll go ahead and get the absolute latest and report back.

I feel like I updated my drivers relatively recently, but I'll go ahead and get the absolute latest and report back.
Author

Got the latest drivers, and I still have the same problem. I tried the CPU based render as well (with OSL off and on), and experienced the same problem I've described, so that ought to rule out GPU drivers as the primary cause.

Got the latest drivers, and I still have the same problem. I tried the CPU based render as well (with OSL off and on), and experienced the same problem I've described, so that ought to rule out GPU drivers as the primary cause.
Richard Antalik added
Status
Needs Triage
and removed
Status
Needs Information from User
labels 2023-07-11 00:22:19 +02:00
Member

Can confirm (even in 4.0), will check

Can confirm (even in 4.0), will check
Philipp Oeser added
Status
Confirmed
Module
Render & Cycles
Interest
Python API
and removed
Status
Needs Triage
labels 2023-07-11 12:46:01 +02:00
Member

Fine in 3.3 LTS, broken in 3.4.0
This broke between 91b88d3d94 and 0ff920b777 , will bisect

109718_ASAN.txt

Fine in 3.3 LTS, broken in 3.4.0 This broke between 91b88d3d9409 and 0ff920b77779 , will bisect [109718_ASAN.txt](/attachments/980706a4-586a-48bf-8817-3f4962df89f5)
Member

Caused by 21acfbe348

CC @brecht

Will raise prio since this is a crash regression (even if not totally recent).

Caused by 21acfbe348a433cb6ef5c422b1da232355fa51ab CC @brecht Will raise prio since this is a crash regression (even if not totally recent).
Philipp Oeser changed title from Cycles render crash using F12 render after running script that uses bpy.ops.render to Regression: Cycles render crash using F12 render after running script that uses bpy.ops.render 2023-07-11 15:06:10 +02:00
Philipp Oeser added
Priority
High
and removed
Priority
Normal
labels 2023-07-11 15:06:16 +02:00
Blender Bot added
Status
Resolved
and removed
Status
Confirmed
labels 2023-07-12 18:15:51 +02:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser Project (Legacy)
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
3 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#109718
No description provided.