Windows + Intel Arc A770: Crashes if modifying the object after rendering image in rendered view mode #109771

Closed
opened 2023-07-06 11:36:39 +02:00 by Blender-King · 20 comments

System Information
Operating system: Windows 10, 21H2
Graphics card: Intel A770

Blender Version
Broken: (example: 2.80, edbf15d3c0, master, 2018-11-28, as found on the splash screen) 3.6.0
Worked: (newest version of Blender that worked as expected) don't know

image

Short description of error
It happens randomly, but when add a plane (with the existing default cube), and try to resize the plane in rendered view mode, Blender crashes with a fairly high probability.

Exact steps for others to reproduce the error
Based on the default startup or an attached .blend file (as simple as possible).
I don't know the exact step. It happens randomly. I attach the blender.crash and configuration files.

**System Information** Operating system: Windows 10, 21H2 Graphics card: Intel A770 **Blender Version** Broken: (example: 2.80, edbf15d3c044, master, 2018-11-28, as found on the splash screen) 3.6.0 Worked: (newest version of Blender that worked as expected) don't know ![image](/attachments/fdc7f545-4d22-42b1-9dda-27afaa8ea04a) **Short description of error** It happens randomly, but when add a plane (with the existing default cube), and try to resize the plane in rendered view mode, Blender crashes with a fairly high probability. **Exact steps for others to reproduce the error** Based on the default startup or an attached .blend file (as simple as possible). I don't know the exact step. It happens randomly. I attach the blender.crash and configuration files.
Blender-King added the
Status
Needs Triage
Type
Report
Priority
Normal
labels 2023-07-06 11:36:39 +02:00

Cant reproduce/

Cant reproduce/
Iliya Katueshenock added the
Interest
Render & Cycles
label 2023-07-06 11:48:08 +02:00

Cant reproduce/

Not sure if related, but when I did was creating a large plane beneath the default cube, to make sort of a floor. Make the plane very big, and then try to keep resizing it fast.

> Cant reproduce/ Not sure if related, but when I did was creating a large plane beneath the default cube, to make sort of a floor. Make the plane very big, and then try to keep resizing it fast.

I changed the size of 4 planes from ~-400 to ~500 with quick cursor jerks within a minute

I changed the size of 4 planes from ~-400 to ~500 with quick cursor jerks within a minute

Issue is specific to Embree on GPU on Windows but I haven't reproduced it with Windows 11 + A750 + driver 101.4369.
The stack trace is different from #109282 but I believe it's related and same fix (still being worked on) should work.

Issue is specific to Embree on GPU on Windows but I haven't reproduced it with Windows 11 + A750 + driver 101.4369. The stack trace is different from #109282 but I believe it's related and same fix (still being worked on) should work.

Issue is specific to Embree on GPU on Windows but I haven't reproduced it with Windows 11 + A750 + driver 101.4369.
The stack trace is different from #109282 but I believe it's related and same fix (still being worked on) should work.

Then, when you fix #109282, I will test this again and close it, if it that fix fixes this too.

> Issue is specific to Embree on GPU on Windows but I haven't reproduced it with Windows 11 + A750 + driver 101.4369. > The stack trace is different from #109282 but I believe it's related and same fix (still being worked on) should work. Then, when you fix #109282, I will test this again and close it, if it that fix fixes this too.
Xavier Hallade self-assigned this 2023-07-06 17:27:46 +02:00

I haven't able to reproduce this issue on few machine with Windows 11 + A770 + driver 101.4502 despite all my attempts. Yet, while there are some similarities to #109282 - I suspect that is may be a different issue, so make sense to put some work on this topic without waiting for the fix (for #109282).
But inability to reproduce it makes it quite hard to investigate/fix it, so, @Blender-King, would you kindly run some adiditonal checks on your side per our requests (as it seems that the issue is reproducible only on your setup) on next week?

I haven't able to reproduce this issue on few machine with Windows 11 + A770 + driver 101.4502 despite all my attempts. Yet, while there are some similarities to #109282 - I suspect that is may be a different issue, so make sense to put some work on this topic without waiting for the fix (for #109282). But inability to reproduce it makes it quite hard to investigate/fix it, so, @Blender-King, would you kindly run some adiditonal checks on your side per our requests (as it seems that the issue is reproducible only on your setup) on next week?

Yeah. Sure.

Yeah. Sure.

I haven't able to reproduce this issue on few machine with Windows 11 + A770 + driver 101.4502 despite all my attempts. Yet, while there are some similarities to #109282 - I suspect that is may be a different issue, so make sense to put some work on this topic without waiting for the fix (for #109282).
But inability to reproduce it makes it quite hard to investigate/fix it, so, @Blender-King, would you kindly run some adiditonal checks on your side per our requests (as it seems that the issue is reproducible only on your setup) on next week?

I'm not sure if I could call this a "good news", but I think I have found a short way to 100% reproduce the crash, at least on my computer. It turned out that I must render a frame, before resizing the plane, otherwise resizing the plane doesn't crash Blender. Here is my screen recording to show the steps.

> I haven't able to reproduce this issue on few machine with Windows 11 + A770 + driver 101.4502 despite all my attempts. Yet, while there are some similarities to #109282 - I suspect that is may be a different issue, so make sense to put some work on this topic without waiting for the fix (for #109282). > But inability to reproduce it makes it quite hard to investigate/fix it, so, @Blender-King, would you kindly run some adiditonal checks on your side per our requests (as it seems that the issue is reproducible only on your setup) on next week? I'm not sure if I could call this a "good news", but I think I have found a short way to 100% reproduce the crash, at least on my computer. It turned out that I must render a frame, before resizing the plane, otherwise resizing the plane doesn't crash Blender. Here is my screen recording to show the steps.
Blender-King changed title from A770 + Bleder 3.6: Randomly crashes when resizing plane in rendered view mode to Windows + Intel Arc A770: Crashes if modifying the object after rendering image in rendered view mode 2023-07-10 03:37:11 +02:00

I did some more tests, and found that it does not have to be a plane or resizing. Just trying to move the default cube also crashed Blender, after calling "render image" when the viewport is in the render view mode.

To illustrate the problem, I recorded the screen from the beginning by clearing Blender's preferences to the end where the crash happened.

I did some more tests, and found that it does not have to be a plane or resizing. Just trying to move the default cube also crashed Blender, after calling "render image" when the viewport is in the render view mode. To illustrate the problem, I recorded the screen from the beginning by clearing Blender's preferences to the end where the crash happened.

Great, thanks a lot - with a video I have able to replicated this issue on my side. I will work on this topic then.

Great, thanks a lot - with a video I have able to replicated this issue on my side. I will work on this topic then.

Thanks a lot for the videos, it's very clear how to reproduce the bug and good catch Nikita: it's indeed a different one than the previously reported one.
I've root caused it down to an issue with embree, I've opened it here: https://github.com/embree/embree/issues/453

Thanks a lot for the videos, it's very clear how to reproduce the bug and good catch Nikita: it's indeed a different one than the previously reported one. I've root caused it down to an issue with embree, I've opened it here: https://github.com/embree/embree/issues/453
Xavier Hallade added
Status
Confirmed
and removed
Status
Needs Triage
labels 2023-07-10 17:02:47 +02:00
Xavier Hallade added this to the 3.6 LTS milestone 2023-07-10 17:02:53 +02:00
Xavier Hallade added this to the Render & Cycles project 2023-07-10 17:02:57 +02:00
Nikita Sirgienko was assigned by Xavier Hallade 2023-07-10 17:03:20 +02:00

You can drop-in the attached embree4.dll in your blender.shared folder. It fixes the issue while we look at the options to get it fixed in official builds.

You can drop-in the attached embree4.dll in your blender.shared folder. It fixes the issue while we look at the options to get it fixed in official builds.

I applied the embree4.dll above and tested Blender a little, and there still is cases of Blender crashing. One procedure is like the following.

  1. Switch to Rendered view.
  2. Minimise Blender and do something else like a watching YouTube video full screen.
  3. After about several minutes, restore Blender window.
  4. Switch to Material Preview view by clicking the 3rd sphere icon.

Blender crashes. I cannot find blender.crash file in temp, so I don't know the error message.

I applied the embree4.dll above and tested Blender a little, and there still is cases of Blender crashing. One procedure is like the following. 1. Switch to Rendered view. 2. Minimise Blender and do something else like a watching YouTube video full screen. 3. After about several minutes, restore Blender window. 4. Switch to Material Preview view by clicking the 3rd sphere icon. Blender crashes. I cannot find blender.crash file in `temp`, so I don't know the error message.

@Blender-King, can you please try to repeat this crash but this time start Blender from the console - and post the last few lines of Blender console output right after the crash?

@Blender-King, can you please try to repeat this crash but this time start Blender from the console - and post the last few lines of Blender console output right after the crash?

Thanks for the report. For this flow, considering the moment of the crash, it's 99% sure it's the same issue as 109282.

Thanks for the report. For this flow, considering the moment of the crash, it's 99% sure it's the same issue as 109282.

The output was "Abort was called at 27 line in file:"

image

The output was "Abort was called at 27 line in file:" ![image](/attachments/54e75855-56b7-4ecc-b8fd-d5e7d289d0f3)

Thanks for the report. For this flow, considering the moment of the crash, it's 99% sure it's the same issue as 109282.

Yeah, it seems that the output is the same. So, just leaving Blender in the rendered view mode seems to count as rendering.

> Thanks for the report. For this flow, considering the moment of the crash, it's 99% sure it's the same issue as 109282. Yeah, it seems that the output is the same. So, just leaving Blender in the rendered view mode seems to count as rendering.
Jesse Yurkovich added
Module
Render & Cycles
and removed
Interest
Render & Cycles
labels 2023-07-16 07:03:07 +02:00
Blender Bot added
Status
Resolved
and removed
Status
Confirmed
labels 2023-07-19 19:40:03 +02:00

Reopening until the libraries are updated accordingly in the deps, so fix shows up in blender.org builds.

Reopening until the libraries are updated accordingly in the deps, so fix shows up in blender.org builds.
Blender Bot added
Status
Needs Triage
and removed
Status
Resolved
labels 2023-07-19 19:43:56 +02:00

This is fixed in latest Blender 4.0 builds: https://builder.blender.org/download/daily/ on both Windows and Linux. Not yet in 3.6, it's expected for next update (3.6.2).

This is fixed in latest Blender 4.0 builds: https://builder.blender.org/download/daily/ on both Windows and Linux. Not yet in 3.6, it's expected for next update (3.6.2).
Xavier Hallade added
Status
Confirmed
and removed
Status
Needs Triage
labels 2023-07-24 12:18:01 +02:00

fix landed in 3.6.2: fd83fdf4f3

fix landed in 3.6.2: https://projects.blender.org/blender/blender/commit/fd83fdf4f3591d40aded81f208fcbcffa7e87d1a
Blender Bot added
Status
Archived
and removed
Status
Confirmed
labels 2023-08-21 11:29:04 +02:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser
Interest
Asset Browser Project Overview
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest: Wayland
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
4 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#109771
There is no content yet.