Overriden material on profile curve does not stick #110755

Closed
opened 2023-08-03 14:11:56 +02:00 by Robert S · 4 comments

System Information
Operating system: Windows-10-10.0.19045-SP0 64 Bits
Graphics card: Quadro RTX 3000 with Max-Q Design/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 536.67

Blender Version
Broken: version: 3.6.1 Release Candidate, branch: blender-v3.6-release, commit date: 2023-07-16 02:43, hash: edc1a09966a7
Worked: (newest version of Blender that worked as expected)

Short description of error
I think I've reported half a dozen bugs with library overrides just today...

Exact steps for others to reproduce the error

  1. Open the link.blend and set the OverrideMaterial on Object_1.006
  2. Save the file
  3. Open link.blend again

Result:

The material on the object has reverted to the original one.

image

Expected:

The material should stay overriden!

image

**System Information** Operating system: Windows-10-10.0.19045-SP0 64 Bits Graphics card: Quadro RTX 3000 with Max-Q Design/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 536.67 **Blender Version** Broken: version: 3.6.1 Release Candidate, branch: blender-v3.6-release, commit date: 2023-07-16 02:43, hash: `edc1a09966a7` Worked: (newest version of Blender that worked as expected) **Short description of error** I think I've reported half a dozen bugs with library overrides just today... **Exact steps for others to reproduce the error** 1. Open the link.blend and set the OverrideMaterial on Object_1.006 2. Save the file 3. Open link.blend again Result: The material on the object has reverted to the original one. ![image](/attachments/e56462bd-0921-47bb-b545-5a5444943594) Expected: The material should stay overriden! ![image](/attachments/89f02ec3-f563-4d83-b1ec-84bae701695a)
Robert S added the
Type
Report
Priority
Normal
Status
Needs Triage
labels 2023-08-03 14:11:57 +02:00

I can reproduce this issue. It's likely, that this is already reported, so will look for duplicate.

I can reproduce this issue. It's likely, that this is already reported, so will look for duplicate.

As noted in 73318, material implementation may not be 100% finished. Similar issue is 101552, so I will close this report as duplicate.

As noted in 73318, material implementation may not be 100% finished. Similar issue is 101552, so I will close this report as duplicate.
Blender Bot added
Status
Archived
and removed
Status
Needs Triage
labels 2023-08-04 01:36:15 +02:00
Author

As noted in #73318, material implementation may not be 100% finished. Similar issue is #101552, so I will close this report as duplicate.

You messed up the links to the other issues. Neither of those issues have a reproducible example attached to them and this one has.

> As noted in #73318, material implementation may not be 100% finished. Similar issue is #101552, so I will close this report as duplicate. You messed up the links to the other issues. Neither of those issues have a reproducible example attached to them and this one has.

I don't think, that repro file is mandatory there. The report i linked is confirmed already. I suggest to subscribe there and when issue is resolved, check if everything works as intended.

I don't think, that repro file is mandatory there. The report i linked is confirmed already. I suggest to subscribe there and when issue is resolved, check if everything works as intended.
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser
Interest
Asset Browser Project Overview
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
2 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#110755
No description provided.