Regression: Bones drawn as stick are invisible #115930

Open
opened 2023-12-08 11:51:14 +01:00 by lucas veber · 3 comments

System Information
Operating system: Windows-10-10.0.19045-SP0 64 Bits
Graphics card: NVIDIA GeForce GTX 1080/PCIe/SSE2 NVIDIA Corporation 4.6.0 NVIDIA 536.99

Blender Version
Broken: version: 4.0.2, branch: blender-v4.0-release, commit date: 2023-12-05 07:41, hash: 9be62e85b727
Worked: 3.6.5

Short description of error
Bones drawn as Stick are invisible when unselected (see Gif attached)

Exact steps for others to reproduce the error

  • Open the blend file (was created with earlier versions of Blender).
  • On the right, switch "Display As" from Octahedral to Stick
  • Bones become invisible
  • Note: when switching to Edit mode and selecting them, they are visible. In Object mode too.

Seems to be related to this, but it is persisting:
#115434

**System Information** Operating system: Windows-10-10.0.19045-SP0 64 Bits Graphics card: NVIDIA GeForce GTX 1080/PCIe/SSE2 NVIDIA Corporation 4.6.0 NVIDIA 536.99 **Blender Version** Broken: version: 4.0.2, branch: blender-v4.0-release, commit date: 2023-12-05 07:41, hash: `9be62e85b727` Worked: 3.6.5 **Short description of error** Bones drawn as Stick are invisible when unselected (see Gif attached) **Exact steps for others to reproduce the error** - Open the blend file (was created with earlier versions of Blender). - On the right, switch "Display As" from Octahedral to Stick - Bones become invisible - Note: when switching to Edit mode and selecting them, they are visible. In Object mode too. Seems to be related to this, but it is persisting: https://projects.blender.org/blender/blender/issues/115434
lucas veber added the
Priority
Normal
Type
Report
Status
Needs Triage
labels 2023-12-08 11:51:15 +01:00
Iliya Katushenock added the
Interest
Animation & Rigging
Interest
EEVEE & Viewport
labels 2023-12-08 13:32:47 +01:00
Iliya Katushenock changed title from Bones drawn as stick are invisible to Regression: Bones drawn as stick are invisible 2023-12-08 13:33:11 +01:00

Seems fixed in 4.1
From what I can see, c9093332e0 has not been backported.
@nathanvegdahl, @Jeroen-Bakker is backporting that commit into 4.0 viable?

Seems fixed in 4.1 From what I can see, c9093332e0 has not been backported. @nathanvegdahl, @Jeroen-Bakker is backporting that commit into 4.0 viable?
Member

It is possible, but it needs to be done manually due to the file versioning code.

It is possible, but it needs to be done manually due to the file versioning code.
Author

The bug is persisting in 4.1
Please see files attached

The bug is persisting in 4.1 Please see files attached
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser
Interest
Asset Browser Project Overview
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
3 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#115930
No description provided.