Can't select bone while Weightpaint with Face PaintMask #83804

Closed
opened 2020-12-15 16:41:31 +01:00 by Ricardo · 9 comments

System Information
Operating system: Windows-10-10.0.19041-SP0 64 Bits
Graphics card: GeForce GTX 1660 SUPER/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 456.71

Blender Version
Broken: version: 2.91.0, branch: master, commit date: 2020-11-25 08:34, hash: 0f45cab862
Worked: Never (2.79+)

Short description of error
Bones can't be selected while in Weightpaint mode and Face Paintmaks option is activated.

Exact steps for others to reproduce the error
Based on the Select with Left Mouse button option and Default Blender Keymap:

PaintMaskAndWeightPaint.blend

1- Open the attached file called PaintMaskAndWeightPaint.blend
2- You see the Cube rigged with 2 bones already in pose mode and cube in Weightpaint mode
3- You can change Bone selection while weightpainting pressing the CTRL + LMB (Left Mouse Button), there is any problem for now
4- Now, if you activate the Face Paint Mask button at the top-left and try to select another bone like before pressing CTRL+LMB on a bone, bone will not be selected, instead of that, you select a face mask. weightpaintaaas.jpg
5- If you go to keymap options, and deactivate the option "Select" from "Weight paint" to avoid select faces with CTRL + LMB, now if you try to select another bone, it will not select another mask face, but it will not select the new bone and will exit the Weight Paint mode.

**System Information** Operating system: Windows-10-10.0.19041-SP0 64 Bits Graphics card: GeForce GTX 1660 SUPER/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 456.71 **Blender Version** Broken: version: 2.91.0, branch: master, commit date: 2020-11-25 08:34, hash: `0f45cab862` Worked: Never (2.79+) **Short description of error** Bones can't be selected while in Weightpaint mode and Face Paintmaks option is activated. **Exact steps for others to reproduce the error** Based on the Select with Left Mouse button option and Default Blender Keymap: [PaintMaskAndWeightPaint.blend](https://archive.blender.org/developer/F9511050/PaintMaskAndWeightPaint.blend) 1- Open the attached file called PaintMaskAndWeightPaint.blend 2- You see the Cube rigged with 2 bones already in pose mode and cube in Weightpaint mode 3- You can change Bone selection while weightpainting pressing the CTRL + LMB (Left Mouse Button), there is any problem for now 4- Now, if you activate the Face Paint Mask button at the top-left and try to select another bone like before pressing CTRL+LMB on a bone, bone will not be selected, instead of that, you select a face mask. ![weightpaintaaas.jpg](https://archive.blender.org/developer/F9511070/weightpaintaaas.jpg) 5- If you go to keymap options, and deactivate the option "**Select**" from "**Weight paint**" to avoid select faces with CTRL + LMB, now if you try to select another bone, it will not select another mask face, but it will not select the new bone and will exit the Weight Paint mode.
Author

Added subscriber: @INeedMana

Added subscriber: @INeedMana

Added subscriber: @mano-wii

Added subscriber: @mano-wii

This behaves like this since old versions of blender (tested om 2.79 and it's the same thing).
So it's not a regression (and maybe not even a bug).
But it seems to be valid to see the opinion of someone from the #animation_rigging team.

This behaves like this since old versions of blender (tested om 2.79 and it's the same thing). So it's not a regression (and maybe not even a bug). But it seems to be valid to see the opinion of someone from the #animation_rigging team.
Author

The thing is, its so annoying when you're adjusting bones weights and you have to change bone, but you cant when you are on facemask mode, its so slow to deactivate facemask to be able to change bone.

Thanks for letting the Animation & Rigging team know about it.

The thing is, its so annoying when you're adjusting bones weights and you have to change bone, but you cant when you are on facemask mode, its so slow to deactivate facemask to be able to change bone. Thanks for letting the Animation & Rigging team know about it.

Added subscriber: @iss

Added subscriber: @iss

Changed status from 'Needs Triage' to: 'Confirmed'

Changed status from 'Needs Triage' to: 'Confirmed'

I would say this is quite explicitly defined behavior, but I don't know if this could be improved easily. I will confirm, so module can consider this case.

I would say this is quite explicitly defined behavior, but I don't know if this could be improved easily. I will confirm, so module can consider this case.
Philipp Oeser removed the
Interest
Animation & Rigging
label 2023-02-09 14:35:56 +01:00
Member

Yeah, I believe this is the intended behavior. But I agree that it's not desireable behavior.

I think this is deserving of a design task. I'll bring it up with the animation module.

Yeah, I believe this is the intended behavior. But I agree that it's not *desireable* behavior. I think this is deserving of a design task. I'll bring it up with the animation module.
Nathan Vegdahl added this to the Animation & Rigging project 2023-06-09 11:20:32 +02:00

I'll consider this fixed with #115409: Fix #44834: Add bone selection icon next to face and vertex selection in weight paint mode

  • Bone selection mode is now explicit
  • It is easy and quick to switch between the modes using 1, 2 and 3
I'll consider this fixed with [#115409: Fix #44834: Add bone selection icon next to face and vertex selection in weight paint mode](https://projects.blender.org/blender/blender/pulls/115409) * Bone selection mode is now explicit * It is easy and quick to switch between the modes using 1, 2 and 3
Blender Bot added
Status
Archived
and removed
Status
Confirmed
labels 2024-02-15 15:18:55 +01:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser Project (Legacy)
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No Assignees
5 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#83804
No description provided.