Rewrite File Browser UI to use views #99890

Open
opened 2022-07-21 17:01:44 +02:00 by Julian Eisel · 4 comments
Member

Views were introduced to simplify and unify UIs with common functionality to display and interact with (possibly large) sets of data. More info:

The Asset Browser should be split off from the File Browser and the file-list backend for a number of important reasons. As part of that a grid view is being developed.

Only doing this and not doing this together with rewriting the File Browser UI raised some concerns for @mont29. So together with him it was decided that both should be looked at. At some point we have to prioritize addressing technical debt too, and not just work on shiny new things. Otherwise we let the code paths diverge significantly, with no plans to address the effective duplication. So both browsers should be ported short-term.


Thumbnail display mode Todo's:

    • Use grid view for drawing thumbnail mode (initial work done in 3a97c4056f)
    • Selection in views (click-select, box select, walk select, etc.)
    • Double click to open
    • Dragging files
    • Context menu
    • Renaming
    • Remove old code (selection, operators, drawing, ...)
    • "Composed" icons as buttons/widgets image.png Current code just draws them in-place, but views use the button/widget system. Alternatively, an overlapping layout can be used, but then there needs to be a way to get the exact preview image size for
    • Superimposed file type icon for previews. Similar problem to the above.

The other display modes should also be ported to views, since otherwise interaction code (selection, renaming, context menu, ...) would have to be duplicated. So:

    • Add new table view
    • Use for Vertical List display mode
    • Use for Horizontal List display mode

We could add an experimental feature flag for this, so development can happen mostly in master. This way the legacy code can stay for a while.

Views were introduced to simplify and unify UIs with common functionality to display and interact with (possibly large) sets of data. More info: - https://wiki.blender.org/wiki/Source/Interface/Views - #98560 (UI Views: General ToDo's) - #95653 (Split Asset and File Browser frontend, implement Grid View) The Asset Browser should be split off from the File Browser and the file-list backend for a number of important reasons. As part of that a grid view is being developed. Only doing this and not doing this together with rewriting the File Browser UI raised some concerns for @mont29. So together with him it was decided that both should be looked at. At some point we have to prioritize addressing technical debt too, and not just work on shiny new things. Otherwise we let the code paths diverge significantly, with no plans to address the effective duplication. So both browsers should be ported short-term. ---- **Thumbnail display mode Todo's:** - - [ ] Use grid view for drawing thumbnail mode (initial work done in 3a97c4056f) - - [ ] Selection in views (click-select, box select, walk select, etc.) - - [ ] Double click to open - - [ ] Dragging files - - [ ] Context menu - - [ ] Renaming - - [ ] Remove old code (selection, operators, drawing, ...) - - [ ] "Composed" icons as buttons/widgets ![image.png](https://archive.blender.org/developer/F13306253/image.png) Current code just draws them in-place, but views use the button/widget system. Alternatively, an overlapping layout can be used, but then there needs to be a way to get the exact preview image size for - - [ ] Superimposed file type icon for previews. Similar problem to the above. The other display modes should also be ported to views, since otherwise interaction code (selection, renaming, context menu, ...) would have to be duplicated. So: - - [ ] Add new table view - - [ ] Use for Vertical List display mode - - [ ] Use for Horizontal List display mode We could add an experimental feature flag for this, so development can happen mostly in master. This way the legacy code can stay for a while.
Author
Member

Added subscribers: @mont29, @JulianEisel

Added subscribers: @mont29, @JulianEisel

Added subscriber: @DuarteRamos

Added subscriber: @DuarteRamos

Added subscriber: @TheRedWaxPolice

Added subscriber: @TheRedWaxPolice
Philipp Oeser removed the
Interest
User Interface
label 2023-02-10 09:21:51 +01:00
Member

Guess this is a design/todo task. Will move this out of triaging list.

Guess this is a design/todo task. Will move this out of triaging list.
Pratik Borhade added
Type
Design
and removed
Status
Needs Triage
Type
Report
labels 2023-05-26 06:36:03 +02:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser
Interest
Asset Browser Project Overview
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
No project
No Assignees
4 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#99890
No description provided.