Keyframes on values of linked data #109781

Closed
opened 2023-07-06 14:47:19 +02:00 by Simon Thommes · 5 comments
Member

System Information
Operating system: Linux-5.17.15-76051715-generic-x86_64-with-glibc2.35 64 Bits, X11 UI
Graphics card: Quadro RTX 6000/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 515.48.07

Blender Version
Broken: version: 3.6.1 Release Candidate, branch: blender-v3.6-release, commit date: 2023-07-05 20:42, hash: 7538127a5806
Worked: (newest version of Blender that worked as expected)

Short description of error
It is currently possible to create keyframes and animation on linked data. This is lost on file save.

Exact steps for others to reproduce the error

  • Link data from one file to another
  • Press I when hovering on any greyed out value of the linked data
**System Information** Operating system: Linux-5.17.15-76051715-generic-x86_64-with-glibc2.35 64 Bits, X11 UI Graphics card: Quadro RTX 6000/PCIe/SSE2 NVIDIA Corporation 4.5.0 NVIDIA 515.48.07 **Blender Version** Broken: version: 3.6.1 Release Candidate, branch: blender-v3.6-release, commit date: 2023-07-05 20:42, hash: `7538127a5806` Worked: (newest version of Blender that worked as expected) **Short description of error** It is currently possible to create keyframes and animation on linked data. This is lost on file save. <video src="/attachments/65f1ac7e-f599-4fce-b5e6-631bbe85fdfa" title="keyframe_linked_data-2023-07-06_14.39.51.mp4" controls></video> **Exact steps for others to reproduce the error** - Link data from one file to another - Press I when hovering on any greyed out value of the linked data
Simon Thommes added the
Type
Report
Status
Needs Triage
Priority
Normal
labels 2023-07-06 14:47:19 +02:00
Sybren A. Stüvel added this to the Animation & Rigging project 2023-07-06 16:08:01 +02:00
Member

I can confirm. Though this is same as Bastien reported in #98712

I can confirm. Though this is same as Bastien reported in #98712
Pratik Borhade added
Module
Animation & Rigging
Status
Confirmed
and removed
Status
Needs Triage
labels 2023-07-07 05:46:48 +02:00
Member

@dr.sybren : shouldnt this be merged with #98712 then?

@dr.sybren : shouldnt this be merged with #98712 then?

this behavior has been in blender at least since 3.0

also if you add a fake user to the action that gets created it stays in the blender file and you can reassign it.
So I think there are two issues:

  1. blender lets you key things you shouldn't key
  2. you can assign an action to an object that is linked and it will animate the object
this behavior has been in blender at least since 3.0 also if you add a fake user to the action that gets created it stays in the blender file and you can reassign it. So I think there are two issues: 1. blender lets you key things you shouldn't key 2. you can assign an action to an object that is linked and it will animate the object
Christoph Lendenfeld self-assigned this 2023-07-07 10:41:14 +02:00
Author
Member

I can confirm. Though this is same as Bastien reported in #98712

Ah, interesting. I was talking with Bastien about this at lunch and he told me to make a report 😅

> I can confirm. Though this is same as Bastien reported in #98712 Ah, interesting. I was talking with Bastien about this at lunch and he told me to make a report 😅

@dr.sybren : shouldnt this be merged with #98712 then?

I feel that that is more like an over-arching issue, and this one is about a specific thing that can be practically solved & marked as closed. So I see this ticket as a 'child' of the other one. Let's not merge, but rather keep them related & close this one when Christoph's fix lands.

> @dr.sybren : shouldnt this be merged with #98712 then? I feel that that is more like an over-arching issue, and this one is about a specific thing that can be practically solved & marked as closed. So I see this ticket as a 'child' of the other one. Let's not merge, but rather keep them related & close this one when Christoph's fix lands.
Blender Bot added
Status
Resolved
and removed
Status
Confirmed
labels 2023-07-13 14:09:59 +02:00
Sign in to join this conversation.
No Label
Interest
Alembic
Interest
Animation & Rigging
Interest
Asset Browser Project (Legacy)
Interest
Asset System
Interest
Audio
Interest
Automated Testing
Interest
Blender Asset Bundle
Interest
BlendFile
Interest
Collada
Interest
Compatibility
Interest
Compositing
Interest
Core
Interest
Cycles
Interest
Dependency Graph
Interest
Development Management
Interest
EEVEE
Interest
EEVEE & Viewport
Interest
Freestyle
Interest
Geometry Nodes
Interest
Grease Pencil
Interest
ID Management
Interest
Images & Movies
Interest
Import Export
Interest
Line Art
Interest
Masking
Interest
Metal
Interest
Modeling
Interest
Modifiers
Interest
Motion Tracking
Interest
Nodes & Physics
Interest
OpenGL
Interest
Overlay
Interest
Overrides
Interest
Performance
Interest
Physics
Interest
Pipeline, Assets & IO
Interest
Platforms, Builds & Tests
Interest
Python API
Interest
Render & Cycles
Interest
Render Pipeline
Interest
Sculpt, Paint & Texture
Interest
Text Editor
Interest
Translations
Interest
Triaging
Interest
Undo
Interest
USD
Interest
User Interface
Interest
UV Editing
Interest
VFX & Video
Interest
Video Sequencer
Interest
Virtual Reality
Interest
Vulkan
Interest
Wayland
Interest
Workbench
Interest: X11
Legacy
Blender 2.8 Project
Legacy
Milestone 1: Basic, Local Asset Browser
Legacy
OpenGL Error
Meta
Good First Issue
Meta
Papercut
Meta
Retrospective
Meta
Security
Module
Animation & Rigging
Module
Core
Module
Development Management
Module
EEVEE & Viewport
Module
Grease Pencil
Module
Modeling
Module
Nodes & Physics
Module
Pipeline, Assets & IO
Module
Platforms, Builds & Tests
Module
Python API
Module
Render & Cycles
Module
Sculpt, Paint & Texture
Module
Triaging
Module
User Interface
Module
VFX & Video
Platform
FreeBSD
Platform
Linux
Platform
macOS
Platform
Windows
Priority
High
Priority
Low
Priority
Normal
Priority
Unbreak Now!
Status
Archived
Status
Confirmed
Status
Duplicate
Status
Needs Info from Developers
Status
Needs Information from User
Status
Needs Triage
Status
Resolved
Type
Bug
Type
Design
Type
Known Issue
Type
Patch
Type
Report
Type
To Do
No Milestone
5 Participants
Notifications
Due Date
The due date is invalid or out of range. Please use the format 'yyyy-mm-dd'.

No due date set.

Dependencies

No dependencies set.

Reference: blender/blender#109781
No description provided.