Nathan Vegdahl nathanvegdahl
  • Amsterdam, Netherlands
  • https://cessen.com
  • Animator, rigger, and software developer. Currently working at the Blender Institute as a developer on Blender's animation system.

    Been using Blender since 1998, and worked on Big Buck Bunny and Sintel (two of Blender's open movie projects).

  • Joined on 2003-03-21
Nathan Vegdahl commented on pull request blender/blender#109015 2023-07-31 17:06:23 +02:00
Animation: Move Snapping to Scene

Since this function is duplicated in three places, maybe it makes sense to just define it once in one place to be reused everywhere? Not sure if there's a semantic difference between the three copies that I'm missing.

Nathan Vegdahl commented on pull request blender/blender#109015 2023-07-31 17:06:23 +02:00
Animation: Move Snapping to Scene

Probably this can just be snap_mode == SCE_SNAP_TO_SECOND now.

Nathan Vegdahl commented on pull request blender/blender#109015 2023-07-31 17:06:22 +02:00
Animation: Move Snapping to Scene

Instead of adding an alias, it might make sense to change the existing name to a new name that encompasses both. Maybe SCE_SNAP_ABS_INCREMENT?

Nathan Vegdahl commented on pull request blender/blender#109015 2023-07-31 17:06:22 +02:00
Animation: Move Snapping to Scene

Is rna_enum_snap_action_element_items used anywhere? I couldn't find it. Then again, RNA stuff still seems a little magical to me sometimes, so I easily could have just missed it.

Nathan Vegdahl commented on pull request blender/blender#110135 2023-07-31 16:12:49 +02:00
Drivers: implement fallback values for RNA path based variables.

Gah! Also, I forgot to report back after the animation & rigging module meeting. The two main things discussed were:

  • We're a bit concerned that this makes the driver editor UI even more
Nathan Vegdahl commented on pull request blender/blender#110074 2023-07-31 15:17:39 +02:00
NLA: Swap strips fixes

@guishe You have both this and #109980 open for fixing #109081. Do you think one or the other is better? And can you elaborate on what the pros/cons of the two different fixes are?

Nathan Vegdahl commented on pull request blender/blender#110301 2023-07-31 15:10:48 +02:00
Animation: Graph Editor curve drawing performance improvement

I have an itchy finger just waiting to hit "approve". 😉 Just waiting on these function renames.

Nathan Vegdahl commented on pull request blender/blender#110544 2023-07-31 14:24:36 +02:00
Animation: Blend Offset Slider

Code looks good to me.

As in #110567 and #110566, I'm not sure what the use case is for this. The closest I can think of is flattening out a section of animation (which definitely comes up, in…

Nathan Vegdahl commented on pull request blender/blender#110566 2023-07-31 14:11:36 +02:00
Animation: Blend To Ease Slider

Might make sense to move the declaration of y_delta inside the for loop below, closer to where it's used.

Nathan Vegdahl suggested changes for blender/blender#110566 2023-07-31 14:11:36 +02:00
Animation: Blend To Ease Slider

Code looks good to me (just one small nit).

Nathan Vegdahl commented on pull request blender/blender#110567 2023-07-31 13:45:10 +02:00
Animation: Match Slope slider

The code looks good to me. But I have a couple of thoughts:

  • The name "Blend to Infinity" was not at all suggestive to me of what this feature does. How does "Blend to Slope" sound?
  • I…
Nathan Vegdahl commented on pull request blender/blender#110567 2023-07-31 13:11:22 +02:00
Animation: Match Slope slider

Nothing to do with this PR, but just a side-note that these fcurve_segment_*_get() functions are (IMO) poorly named. I would expect them to get the first and last keys within the selected segment, but in fact they attempt to get the keys before and after the segment, which are not themselves part of the segment (falling back to the actual start and end key of the segment only if the before/after don't exist).

Nathan Vegdahl pushed to main at nathanvegdahl/blender 2023-07-31 12:26:42 +02:00
89811cb96f Cleanup: unused-imports in tests/
d7558a243c Keymap: avoid 3D View transform inheritance
932a85a24f Fix tests failing from errors in the users startup file
b248295530 Depsgraph: handle camera switching via markers in context drivers.
406f601c4b Depsgraph: change the fix for #107081 to handle any Scene references.
Compare 37 commits »
Nathan Vegdahl commented on pull request blender/blender#110135 2023-07-31 12:02:40 +02:00
Drivers: implement fallback values for RNA path based variables.

If a "fallback" to use a default value considered an error then it feels that the default value is just there to help hiding the error, which is not really good. If use of a default value is…

Nathan Vegdahl commented on pull request blender/blender#106355 2023-07-31 08:49:19 +02:00
Replace Default OCIO config with AgX (Filmic v2)

This is only true if we will never change the working space to BT.2020 or ACEScg in the future.

Or if we explicitly provide a linear sRGB/Rec.709 output display transform, which is the…

Nathan Vegdahl commented on pull request blender/blender#106355 2023-07-30 17:15:42 +02:00
Replace Default OCIO config with AgX (Filmic v2)

But we will go with piece-wise for this project, as confirmed by Sergey. Whether sRGB should be changed to 2.2 will be a discussion separated from this current one.

Yeah, that's a good…

Nathan Vegdahl commented on pull request blender/blender#106355 2023-07-28 11:26:49 +02:00
Replace Default OCIO config with AgX (Filmic v2)

Most of what has been discussed here so far makes sense to me, aside from some subtleties that we may want to consider at some point. I'll post about those later when I have time to collect my…

Nathan Vegdahl commented on pull request blender/blender#110301 2023-07-27 15:15:32 +02:00
Animation: Graph Editor curve drawing performance improvement

and there might be others reading the code that never heard of it either.

Totally fair! And indeed, you not knowing what it meant is probably a good indication to avoid the math jargon…

Nathan Vegdahl commented on pull request blender/blender#110301 2023-07-27 15:03:02 +02:00
Animation: Graph Editor curve drawing performance improvement

Oh, that's a good point. But rather than changing what they return, I wonder if just changing the names to get_extrapolation_point_left/right would make sense. Then they're consistent with…

Nathan Vegdahl commented on pull request blender/blender#110301 2023-07-27 14:43:47 +02:00
Animation: Graph Editor curve drawing performance improvement

I was puzzling if this or max(resolution_x, resolution_y) makes more sense. And I've come to the tentative conclusion that summing is probably not only better than max but actually even better than the square-root (Euclidean) distance calculation.